Unable to start webserver with HTTPS for WebRTC

So, I would like to make a web VoIP (audio and video) app with Asterisk and SIP.js.
I know what I have to do. I already configured everything but the Asterisk web server won’t start with HTTPS enabled. (Note: I tried using 16.2.0-rc2 and 15.7.X) Right now, it’s just a local machine.
The output for “http show status” is:

HTTP Server Status:
Server: Asterisk
Server Enabled and Bound to

Enabled URI’s:
/httpstatus => Asterisk HTTP General Status
/phoneprov/… => Asterisk HTTP Phone Provisioning Tool
/static/… => Asterisk HTTP Static Delivery
/ari/… => Asterisk RESTful API
/ws => Asterisk HTTP WebSocket

Enabled Redirects:

My “/etc/asterisk/http.conf”:
tlscertfile=/etc/asterisk/keys/asterisk.pem ; here I tried to use the .crt file…
tlsprivatekey=/etc/asterisk/keys/asterisk.key ; also tried asterisk.pem here… to no avail.

“netstart -tulpn”: no sign of 8089

I used the wiki: https://wiki.asterisk.org/wiki/display/AST/Configuring+Asterisk+for+WebRTC+Clients
And also this (for extensions):

Note: In my “/var/log/asterisk/messages”, no mention of HTTP or something that can help.
Feel free to ask for more information. Thanks in advance.

Ok, I am a PEBKAC. I followed the guide with root commands and my asterisk was running with a separate user… so I had to change permissions. Just a tip for all of you.
Troubleshooting for like 4 hours… :sweat_smile: :disappointed_relieved:


I am using asterisk with root user and installed webRTC but it is not running.
please give me complete guide of webRTC as i am new with asterisk. i got error on cli:
res_http_websocket.c:793 __ast_websocket_uri_cb: WebSocket connection from ‘X.X.X.X:62878’ could not be accepted - did not request WebSocket

Please create a new thread instead of using someone elses.