Unable to load pbx_config.so in Asterisk 16.6.1


I recently started working on asterisk 16 and getting a strange issue. I am using pjsip realtime and creating dialplan in extconfig config file. But asterisk is not able to read text-based dialplan because of that module.

I tried loading that module manually and via modules.conf but still not able to load that pbx_config.so module. File permissions look perfect too. I am getting this error when I try to load that module -
Nov 2 18:22:48] ERROR[1730] loader.c: pbx_config declined to load.
[Nov 3 23:29:38] VERBOSE[4477] loader.c: Loading pbx_config.so.
[Nov 3 23:29:39] ERROR[4477] loader.c: pbx_config declined to load.
[Nov 3 23:43:26] VERBOSE[4654] loader.c: Loading pbx_config.so.
[Nov 3 23:43:26] ERROR[4654] loader.c: pbx_config declined to load.

Please help me out to troubleshoot this issue. I would appreciate that.

Thank you

try creating extensions.conf file manually and then load the module again

Thank you very much. That solved the problem.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.