Unable to create channel of type 'SIP' after 'sip reload'


There is asterisk 11 server with realtime configuration, and my problem is that sip registration don’t work after a “sip reload” command and off course asterisk shows this error

Unable to create channel of type ‘SIP’

Make sure you have “rtcachefriends=yes” in the general section of your sip.conf file. You may also want to set the qualify on your clients to 60 (or yes, or some other number in seconds).

Also try:
sip prune realtime {extension}
sip show (extension} load

Obviously replace {extension} with the actual extension number.

thanks for answer

yes, i have rtcachefriends and also i tried qualify=yes, but when sip peers are cached everything works fine and when i type command ‘sip reload’, peers disappear, app_dial don’t work and status is UNREACHABLE.

I changed sipregs location in extconfig.conf and problem solved.

same as sippers and sipusers

Most of the time if Asterisk cant find the configuration file for a module it wont load the module , in your case Asterisk was not able to load the configuration from your DB and that was blocking the sip module to load