UK Tone settings

Dear All, We have been using Asterisk for some time and its works the way we wanted it to…Asterisk is running on VOIP SIP platform. I wanted Asterisk to provide UK busy tone, where in, a UK telecom provider(BT) will detect the Busy tone and redirect the call to a different phone in UK…I have tried the Indications.conf with UK setting and I tried redirecting the call to an extension with playtones(400/375,0/375), and I tried UK busy tone recording all three options didn’t work. Can somebody please help me. If this works my company will get an Inbound project.

Thanks in advance…
Babu…

That’s not how BT’s network works. If you want to signal busy upstream, you will need ISDN, although, as I’ve never used ISDN with Asterisk so I can’t offer guarantees.

You can’t generate busy tone on an analogue FXO line until you have answered the call, at which point it is too late to indicate busy to the upstream network.

In fact, for a normal analogue caller, busy tone will only exist between the caller’s concentrator switch (exchange) and the caller.

What sort of BT connection do you have? I am running Asterisk servers on both ISDN-30 and ISDN-2.

Dear All, Thanks for the response…

Just to let you know that our centre is in India. I have a VOIP over MPLS with a local provider. We dial UK, US, Australia, Canada and its all working fine…
Now, BT as provider dials the calls for a prospective Client in UK, which is an Inbound call for me, when BT detects the busy tone when all our agents are busy he redirects the call to some other location…As in my first post, I have tried those options, but my client has reverted back saying that his provider’s (BT) system is not detecting the busy tone…
Once again saying, If I get this working, Client is ready to get the project running…

Somebody give pointer to some doc…

Thanks
Babu…

BT DO NOT listen to in band tones to detect busy.

You need to reject the call with ISDN cause 17 (although 21 might be more accurate). networking.ringofsaturn.com/Rout … ecodes.php

If you have a direct ISDN connection, Hangup(17), issued before Answer should do it and Busy(), before Answer should do it.

If you have SIP to an ISDN interface, you are at the mercy of the intermediate nodes and how they translate SIP causes to ISDN ones, but the above Hangup and Busy calls may work, if you have a good SIP to ISDN route.

It is just possible that BT will recognize special inforamation tones, from a network operator, in early media, but you are probably not considered a network operator and you are probably not allowed early media. I have no evidence that they do accept them. en.wikipedia.org/wiki/Special_information_tones

Thanks David for that,

Sorry was offline for some time…

I am in India the PRI(ISDN) is provided by the local provider(VSNL/TATA). I have done the below test…

  1. Terminated the ISDN PRI on a Nortel Switch, their the busy is by default Cause code 17, as per the vendor, but the busy sounded kind of double tone I am not sure if it was UK tone and the client reverted back with no results.

  2. Then terminated the same link(PRI) to the ASterisk with Sangoma A101 card. Here again I have set the cause code 17 with same result ie., kind of double tone, I am not very sure if that is US tone, even after the zone is set to UK in the Dahdi config.

  3. I then gave a Busy(), I get a UK busy tone since the zone is set to UK, but without cause code 17…

  4. What I want is this, UK tone with cause code 17, how to set this in Asterisk-Dahdi config.

I have gonna give three options(2,3,4) to the client I not sure which ever will work or not…option 4 I am yet to configure…

Infact the Client has outsourced similar process in india, they are using Audiocode Mediant 1000 voice gateway. he had given me a test number to actually check how the UK Busy sounds, When I dialed through ASterisk-PRI with debug enabled, I could see the call terminating with cause code 17…This UK tone is the one I could not simulate in AStersik with cause code 17

Somebody please help me…
Thanks in advance…
Babu