Ubuntu-9.10- Karmic Koala


Will the upgrade from Jaunty jacklope to Karmic Koala affect my installed asterisk and dialplan?

I still didn’t go fo the upgrade.


no i think…i have updated last week and my asterisk 1.6.2.x works well…


Thanks, I did upgrade.

Asterisk-1.6.0 works well too. Provided I skipped the upgrade for etc/asterisk/extensions.conf and etc/asterisk/sip.conf file.

If you use dahdi you will have problems and you will need to upgrade dahdi.

I only skipped the upgrade of sip. conf and extensions.conf, other than that I upgraded all other conf files.

Hi i have recently installed asterisk onto Ubuntu 9.10 and have ran into a dahdi problem!

i have installed the following components

i have installed dhadi-
make clean
make install

make install
make config

but when i try the command dahdi_tool

it retrurns but was told “no such command”

any ideas??

I think Dahdi works really well with asterisk-1.6.0 rather than asterisk- I’m not very sure whether that’s the problem.

I’m bit surprised, coz when I upgraded to Ubuntu-9.10, a pop-up was displayed saying that Karmic, might change the conf files, so to keep old conf files click keep or else remove ( old conf file replaced by new one )

In my case, since I already had a dial-plan up and running. I didn’t want to replace the sip.conf and extensions.conf files, that’s why went for KEEP option rather than REMOVE.

thanks for the reply!

okey dokey

i would prefer to use Zap to be honest, as i already have a huge dialplan from my 1.4.7 asterisk box

i think i will flatten the machine and start again and will try and install zap (if i can)


The one solution is, first upgrade your machine to Karmic Koala and then install Asterisk, Zaptel and libpri from scratch.

Provided, I would take a back-up of the dialplan before upgrade.

Good Luck!

Most important, install zaptel and libpri before asterisk. If you run asterisk before zaptel or libpri, it’ll run without zaptel drivers and so when you type the command it shows No such tools or commands. Coz asterisk would not recognize it, if you run zaptel after asterisk.

right totally started form new…even reinstalled ubuntu!

now im getting an issue when trying to install Zap, i think its an issue with ubuntu though?

/usr/src/zaptel- In function ‘ztdummy_hr_int’: /usr/src/zaptel- error: ‘struct hrtimer’ has no member named ‘expires’ make[3]: *** [/usr/src/zaptel-] Error 1 make[2]: *** [_module_/usr/src/zaptel-] Error 2 make[2]: Leaving directory `/usr/src/linux-headers-2.6.31-14-server' make[1]: *** [modules] Error 2 make[1]: Leaving directory `/usr/src/zaptel-

Your kernel is too recent for you to be able to install an old, zaptel based, Asterisk.

ahh crap!

i think im correct in thinking you cant “downgrade” a kernel too.

i already have an existing dialplan, made for zap which is huge, hence why i wanted to use 1.4

so i have to install 1.6 with dahdi?

dahdi is the standard for current versions of 1.4. The basic problem is that zaptel is no longer maintained, so, if a kernel change breaks it, you are in trouble.

ahh right ok i understand, when i have tried to install dahdi on the latest version of 1.4 (the one available from the digium site) the installation failed.

i will flatten the machine again, just in case there are any incompatabilities with having bits of zap lying around. and will install the dahdi and dahdi tools

thanks for you advice :smile:

right again taking it back to a clean install of 9.10 and tried to install dahdi

trying to use dahdi-linux-complete-

/usr/src/asterisk/dahdi-linux-complete- error: ‘struct net_device’ has no member named ‘open’ /usr/src/asterisk/dahdi-linux-complete- error: ‘struct net_device’ has no member named ‘stop’ /usr/src/asterisk/dahdi-linux-complete- error: ‘struct net_device’ has no member named ‘hard_start_xmit’ /usr/src/asterisk/dahdi-linux-complete- error: ‘struct net_device’ has no member named ‘get_stats’ /usr/src/asterisk/dahdi-linux-complete- error: ‘struct net_device’ has no member named ‘do_ioctl’ make[4]: *** [/usr/src/asterisk/dahdi-linux-complete-] Error 1 make[3]: *** [/usr/src/asterisk/dahdi-linux-complete-] Error 2 make[2]: *** [_module_/usr/src/asterisk/dahdi-linux-complete-] Error 2 make[2]: Leaving directory `/usr/src/linux-headers-2.6.31-14-server' make[1]: *** [modules] Error 2 make[1]: Leaving directory `/usr/src/asterisk/dahdi-linux-complete-

any one?!?!?

has anyone got asterisk to work on Ubuntu 9.10?

You may need a development build. I don’t believe that there is an open issue for that kernel, but the change may not have reached the release version.

ohh this is sounding messy!

im not the hottest on linux coding

is the only way around this issue to use an older version of Ubuntu?

edit my current Kernel 2.6.31-14-server

Yup, asterisk-1.6 is working fine in my Linux system ( Ubuntu-9.10, Karmic Koala )

Can you just brief me in layman terms, how you actually Installed asterisk in your Ubutnu-9.10?

I can help you by giving step-by-step explanation of what I did.


firsty i have installed ubuntu-desktop (it makes it easier navigating)

i have downloaded:




apt-get install linux-headers-$(uname -r) bison openssl libssl-dev libeditline0 libeditline-dev gcc make g++ mc php5-cli

untar all files into /usr/src/asterisk
cd to dahdi-linux-complete-
make all

thats when i got the last errors.