Troubleshoot phone registration, not seeing anything in CLI

Trying to make a Cisco 7942 register. It get’s a label and a line, but says “registering” for a long time and doesn’t register.

Using PJSIP- pjsip show registrations says No objects found.

I do #asterisk -rdvvvvv and get localhost*CLI>. I reboot phone, but I don’t see any messages regarding phone.

I see messages like this, but nothing about phone:

[2017-11-17 10:27:01] DEBUG[2927]: manager.c:6313 process_message: Running action ‘Login’
[2017-11-17 10:27:27] DEBUG[2921]: manager.c:6313 process_message: Running action ‘Command’

Why don’t I see any messages regarding phone registration?



Make sure iptables , firewall are not blocking traffic, also use nestat -apn | grep asterisk to verify on what port asterisk is listening for pjsip

try a ‘pjsip show endpoints’

the ‘pjsip show registrations’ command shows outbound registrations not incoming ones.

You may also want to try ‘pjsip set logger on’ and see what packets your PBX is receiving from your phone.

Thanks for your reply’s. pjsip set logger on fixed it.

Now I see Unauthorized message sent to phone. Now I can try to fix that, suggestions welcome.

<— Received SIP request (699 bytes) from UDP: —>
Via: SIP/2.0/UDP;branch=z9hG4bKab4cb23a
From: sip:6000@;tag=0c272431fd070007e712c8f3-5a188840
To: sip:6000@
Call-ID: 0c272431-fd070002-012444d8-2fe5e94c@
Max-Forwards: 70
Date: Fri, 17 Nov 2017 16:46:46 GMT
User-Agent: Cisco-CP7942G/8.5.2
Contact: sip:6000@;transport=udp;+sip.instance=“urn:uuid:00000000-0000-0000-0000-0c272431fd07”;+u.sip!"434"
Supported: (null),X-cisco-xsi-7.0.1
Content-Length: 0
Reason: SIP;cause=200;text="cisco-alarm:20 Name=SEP0C272431FD07 Load=SIP42.8-5-2SR1S Last=phone-keypad"
Expires: 3600

<— Transmitting SIP response (530 bytes) to UDP: —>
SIP/2.0 401 Unauthorized
Via: SIP/2.0/UDP;rport=49156;received=;branch=z9hG4bKab4cb23a
Call-ID: 0c272431-fd070002-012444d8-2fe5e94c@
From: sip:6000@;tag=0c272431fd070007e712c8f3-5a188840
To: sip:6000@;tag=z9hG4bKab4cb23a
WWW-Authenticate: Digest realm=“asterisk”,nonce=“1510937214/ee4c5a495eee2d2fe200810192b20abc”,opaque=“25386842618473e7”,algorithm=md5,qop="auth"
Server: FPBX-
Content-Length: 0

The “force_rport” option must be set to “no” for Cisco. They don’t adhere to the RFC and need the response to go back to where they say, and not the source.


You are awesome! fixed

To expand on that. The problem is not the Unauthorised, it is the fact that it never reaches the client. Unauthorised is correct at this point.

So now it can make calls, but still shows Unavailable in pjsip show endpoints and cannot receive calls.

The rewrite_contact option also has to be set to “no”.


fixed again. Thanks so much for saving many hours of my life!

I have another customer on Switchvox. Looks like force_rport and rewrite_contact can’t be changed on Switchvox, right?

You would need to contact Digium Technical Support for help on that.

1 Like