Trouble using DTMF for MeetMe Conference

Hi guys,

i have a Setup on a Raspberry Pi 2 with Asterisk 11.21.0 and FreePBX 13.0.79 from I’m using the Conference System and it is doing very well. My problem is the use of DTMF for the Conference Pin.

Mostly it is working without a problem, but in some cases, Asterisk doesn’t recognize that I am entering an pin at all. Ist always the same phone, where I tried it.

I tried to use inbound, rfc2833 and auto, but it’s always the same. If it worked correctly, the log says:
[2016-03-14 13:23:48] VERBOSE[7457][C-0000000d] app_read.c: – User entered ‘1234’

[2016-03-14 13:24:14] VERBOSE[7459][C-0000000e] app_read.c: – User entered nothing.

The rest of the log seems to be identically.

In all cases, when Asterisk doesn’t recognize the PIN, it asks several times to enter the conference pin, but it never recognizes any number until i hang up and dial again.

Any idea, what can be done? Upgrading to Asterisk 13?

Thank you in advance!

How are you set up to receive DTMF, Inband or RFC2833? and how is your sip provider setup?( I assume you are having problems with calls from a ITSP).

Hi! My settings are the following:

Advanced Settings - SIP DTMF Signaling - rfc2833
Trunks - SIP Settings - Incoming - rfc2833

SIP-Gate says, it uses rfc4733. I tried it with this setting in “Trunks / SIP Settings”, but it was the same problem.

Yes - it only occurs, if I try to call from a ITSP (sipgate). If I’m calling the conference internal, there is no problem.