Transfer problems on 1.4

I see several other posts here about this, and I am having no luck in resolving it.

Running Asterisk 1.4 (zaptel, libpri , etc… all 1.4)
CentOS 4.4 (It’s not a trixbox)


transferdigittimeout => 3
featuredigittimeout = 500


blindxfer => #1
disconnect => **

exten => 102,1,Dial(SIP/102,20,t)
exten => 102,2,Voicemail(102,u)
exten => 102,3,Hangup
exten => 103,1,Dial(SIP/103,20,t)
exten => 103,2,Voicemail(103,u)
exten => 103,3,Hangup
exten => 104,1,Dial(SIP/104,20,t)
exten => 104,2,Voicemail(104,u)
exten => 104,3,Hangup
exten => 105,1,Dial(SIP/105,20,t)
exten => 105,2,Voicemail(105,u)
exten => 105,3,Hangup

Etc… when I dial the extension from the main DID line… it seems like it just isnt listening for the transfer digits. No matter what I press or what I set the blindxfer digit(s) to be. I tried a single digit as well, no avail.

I did tests to make sure it was picking up the DTMF digits and it is working fine. ( went through logging into voicemail, also tested by doing exten => #1,1,Playback(tt-weasels)

I used this function before on 1.2 and I assumed it would be fine here as well. As long as I pass the t ( or T for caller ability to transfer) in the Dial() command.

Any thoughts?

any insight as to why this would not work, or why Asterisk does not seem to be listening for DTMF on a bridged call would be greatly appreciated. Here is the output from feature show in the CLI

asterisk1*CLI> feature show
Builtin Feature Default Current

Pickup *8 *8
Blind Transfer # #1
Attended Transfer
One Touch Monitor *1
Disconnect Call * **
Park Call

Dynamic Feature Default Current


Call parking

Parking extension : 700
Parking context : parkedcalls
Parked call extensions: 701-750[/code]

does this work on a station to station call? meaning one phone to another? it might be that after the call is established the VOIP provider isnt sending DTMF through to the asterisk?

maybe use dtmfmode=inband and see if that makes a difference.


I don’t know if this would help you, but I had a devil of a time getting any dynamic features (blind xfer, automon, etc.) to work until I put ‘canreinvite=no’ in my sip.conf for each account.

From what I’ve read, having ‘t’ or ‘T’ (or in the case of automon ‘w’ or ‘W’) in the Dial extension is supposed to handle this, but it wasn’t for me (asterisk 1.4)

you have to have canreinvite=no otherwise the connection from phone to phone is native and asterisk isnt monitoring the connection… if asterisk isnt “in the middle” you cant use any dynamic features…

that seems to be the consensus now … but until 1.4, it was deemed sufficient to include a dialstring option that would prevent Asterisk from issuing a reinvite.