The user part of the contact header

When I try to redirect the call, my current contact header in invite section is sip:asterisk@server ip:port. Is it possible to substitute the user part for the callerid? I tried the use_callerid_contact configuration option, but it did not work.

You’ll need to specify which SIP channel driver you are referring to and the version of Asterisk.

My channel driver is PJSIP. I am using Asterisk 15.

Asterisk 15 has not been supported for some time and as a result never received the “use_callerid_contact” functionality.

Should I upgrade it to Asterisk 16?

Asterisk 16 has such functionality, and you see dates and such on the wiki[1].


Thank you very much. I will try to upgrade my freePBX setup.

I have updated Asterisk to version 16.3.0, but with this switch endpoints do not work.

If you are using FreePBX then that is likely something you would need to investigate there instead of Asterisk itself.

Thank you. I will try.

I put this setting in the wrong place. It must be a global setting, not an endpoint setting.

The documentation notes it as a global, not an endpoint option: