tdm400p (1fxo 1fxs) + hfc pci + x101p tribox 2

I have a problem after install-ZAPHFC, asterisk dont want to start.
the channel 1 2 et 5 of my tdm400p and x101p work fine before install hfc.

#ztcfg -vv

Zaptel Configuration

SPAN 1: CCS/ AMI Build-out: 399-533 feet (DSX-1)

Channel map:

Channel 01: FXS Kewlstart (Default) (Slaves: 01)
Channel 02: FXO Kewlstart (Default) (Slaves: 02)
Channel 05: FXS Kewlstart (Default) (Slaves: 05)
Channel 06: Clear channel (Default) (Slaves: 06)
Channel 07: Clear channel (Default) (Slaves: 07)
Channel 08: D-channel (Default) (Slaves: 08)

6 channels configured.

#cat /proc/zaptel/*

Span 1: WCFXO/0 “Wildcard X101P Board 1”

1 WCFXO/0/0 FXSKS
Span 2: WCTDM/0 “Wildcard TDM400P REV I Board 1”

2 WCTDM/0/0 FXOKS
3 WCTDM/0/1
4 WCTDM/0/2
5 WCTDM/0/3 FXSKS
Span 3: ZTHFC1 “HFC-S PCI A ISDN card 0 [TE] layer 1 ACTIVATED (F7)” AMI/CCS

6 ZTHFC1/0/1 Clear
7 ZTHFC1/0/2 Clear
8 ZTHFC1/0/3 HDLCFCS

#cat /proc/interrupts
CPU0
0: 1487580 XT-PIC timer
1: 8 XT-PIC i8042
2: 0 XT-PIC cascade
5: 1451793 XT-PIC wcfxo
7: 1446989 XT-PIC wctdm
8: 1 XT-PIC rtc
10: 18902 XT-PIC VIA8233, eth0
11: 8939536 XT-PIC zaphfc
12: 66 XT-PIC i8042
14: 4646 XT-PIC ide0
15: 13047 XT-PIC ide1
NMI: 0
ERR: 0

#amportal start

SETTING FILE PERMISSIONS
Permissions OK

STARTING ASTERISK
Asterisk ended with exit status 1
Asterisk died with code 1.
Automatically restarting Asterisk.
Asterisk ended with exit status 1
Asterisk died with code 1.
Automatically restarting Asterisk.
mpg123: no process killed


Asterisk could not start!
Use ‘tail /var/log/asterisk/full’ to find out why.

#tail /var/log/asterisk/full

Jan 24 01:47:06 VERBOSE[4694] logger.c: == Parsing ‘/etc/asterisk/zapata-BRI-HFC.conf’: Jan 24 01:47:06 VERBOSE[4694] logger.c: == Parsing ‘/etc/asterisk/zapata-BRI-HFC.conf’: Found
Jan 24 01:47:06 DEBUG[4694] chan_zap.c: Updated conferencing on 1, with 0 conference users
Jan 24 01:47:06 VERBOSE[4694] logger.c: – Registered channel 1, FXS Kewlstart signalling
Jan 24 01:47:06 WARNING[4694] chan_zap.c: Unable to specify channel 2: No such device
Jan 24 01:47:06 ERROR[4694] chan_zap.c: Unable to open channel 2: No such device
here = 0, tmp->channel = 2, channel = 2
Jan 24 01:47:06 ERROR[4694] chan_zap.c: Unable to register channel '2’
Jan 24 01:47:06 WARNING[4694] loader.c: chan_zap.so: load_module failed, returning -1
Jan 24 01:47:06 VERBOSE[4694] logger.c: – Unregistered channel 1
Jan 24 01:47:06 WARNING[4694] loader.c: Loading module chan_zap.so failed!


/etc/zaptel.conf

Span 1: WCFXO/0 “Wildcard X101P Board 1”

fxsks=1

Span 2: WCTDM/0 “Wildcard TDM400P REV I Board 1”

fxoks=2

channel 3, WCTDM, inactive.

channel 4, WCTDM, inactive.

fxsks=5

Span 3: ZTHFC1 “HFC-S PCI A ISDN card 1 [TE]”

span=3,1,3,ccs,ami
bchan=6-7
dchan=8

Global data

loadzone = fr
defaultzone = fr


/etc/asterisk/zapata-auto.conf

callerid=asreceived

; Span 1: WCFXO/0 "Wildcard X101P Board 1"
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 1
context=from-zaptel
group=1
channel => 1

; Span 2: WCTDM/0 "Wildcard TDM400P REV I Board 1"
signalling=fxo_ks
; Note: this is an extension. Create a ZAP extension in AMP for Channel 1
context=from-internal
group=0
channel => 2

; channel 2, WCTDM, inactive.
; channel 3, WCTDM, inactive.
signalling=fxs_ks
; Note: this is a trunk. Create a ZAP trunk in AMP for Channel 4
context=from-zaptel
group=0
channel => 5

; Span 3: ZTHFC1 “HFC-S PCI A ISDN card 1 [TE]”
; ??: 6 ZTHFC1/0/1
; ??: 7 ZTHFC1/0/2
; ??: 8 ZTHFC1/0/3

; Span 4: ZTDUMMY/1 “ZTDUMMY/1 1”


/etc/asterisk/zapata.conf

[trunkgroups]

[channels]

language=fr
context=from-zaptel
signalling=fxs_ks
rxwink=300 ; Atlas seems to use long (250ms) winks
;
; Whether or not to do distinctive ring detection on FXO lines
;
;usedistinctiveringdetection=yes

usecallerid=yes
hidecallerid=no
callwaiting=yes
usecallingpres=yes
callwaitingcallerid=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=yes
echocancelwhenbridged=no
echotraining=800
rxgain=0.0
txgain=0.0
group=0
callgroup=1
pickupgroup=1
immediate=no

;faxdetect=both
faxdetect=incoming
;faxdetect=outgoing
;faxdetect=no

;Include genzaptelconf configs
#include zapata-auto.conf

group=1

;Include AMP configs
#include zapata_additional.conf

;Include BRI-HFC configs
#include zapata-BRI-HFC.conf


/etc/sysconfig/zaptel

TELEPHONY=yes
#DEBUG=yes

Un-comment as per your requirements; modules to load/unload

genzaptelconf will populate this file

#Module Name Hardware
#MODULES="$MODULES tor2" # T400P - Quad Span T1 Card

E400P - Quad Span E1 Card

#MODULES="$MODULES wct4xxp" # TE405P - Quad Span T1/E1 Card (5v version)

TE410P - Quad Span T1/E1 Card (3.3v version)

#MODULES="$MODULES wct1xxp" # T100P - Single Span T1 Card

E100P - Single Span E1 Card

#MODULES="$MODULES wcte11xp" # TE110P - Single Span T1/E1 Card

MODULES="$MODULES wcfxo" # X100P - Single port FXO interface

X101P - Single port FXO interface

MODULES="$MODULES wctdm" # TDM400P - Modular FXS/FXO interface (1-4 ports)
MODULES="$MODULES wcfxs" # either above or this

#MODULES="$MODULES wcusb" # S100U - Single port FXS USB Interface
#MODULES="$MODULES wcfxsusb" # either above or this

#MODULES="$MODULES torisa" # Old Tormenta1 ISA Card

#MODULES="$MODULES ztdummy" # UHCI USB Zaptel Timing Only Interface

MODULES="$MODULES zaphfc" # HFC ISDN module