Strange issue - HELP NEEDED


#1

This puzzle is still lurking for me. I have a sip DID
provider. My registration to the provider works fine. I haven’t opened up
externip and localnet in my sip.conf file but in my router forwarded ports
5060-5061 and 10000-20000 to my asterisk box.
When i dial my DID number it comes through fine and i can hear the
greeting with “please enter your password” message
but when i enter password number on my phone, the signal doesn’t reach my asterisk so the system waits and says “no passwrod entered”.
I can’t see a reason why this is happening.

My DID provider’s IP is for example 220.238.44.999. I have only allowed
ports 5060-5061 and 10000-20000 for that IP in my firewall and router. My asterisk is 1.2.x (latest). My phone is a normal pstn cordless phone.

Any suggested will be received gratefully.
[/b]


#2

sounds like a DTMF issue. make sure that all parties are expecting the other ends DTMF, the codec being used makes a difference too. you don’t say where your cordless phone fits in here, so i’m not sure what that has to do with anything.


#3

Hi,
thanks for giving me some direction. My cordless phone is not connected to asterisk or the network. Its just my nomal home phone (landline) independent of asterisk.
My DTMF is RFC2833 which is what was advised by my DID provider. Please let me know what extra info i can provide you with to diagnose this issue.

Homephone-> call DID-> rings my asterisk box->terminates to PSTN

My another DID with IAX works fine and can get all the passwords or keys pressed from the normal home phone but but with SIP it doesn’t get that signal.

thanks and hope to hear from you…


#4

Sounds like a typical SIP problem…run into this stuff a lot. Could be a couple of things, but likely just a port problem. Any difference if you put your PBX on a DMZ?

It might not be just DTMF, you might be only getting voice in one direction. If you forward your DID directly to a voicemail box…can you record a message or just hear the greeting?

What it most likely is, is in your sip.conf file, for your extension…make sure that nat=yes is set.

Somthing to check is your sip_nat.conf file is populated

externip=your external IP
localnet=your asterisk boxes internal IP/255.255.255.0

something like

externip=184.212.33.21
localnet=192.168.20.0/255.255.255.0


#5

Thanks for the suggestions. My asterisk box is inside nat and I haven’t yet tried it as a DMZ because some other small services run through it. When i specify externip and local net i can’t register with my sip provider it says “provider unreachable” but without it, i can register fine. The call from DID comes through fine and the funny thing is, I can sometimes hear sound and ther other times sound can’t be heard even though asterisk is doing the right thing. So the problems are:

  1. inconsistant sounds sometimes can be heard and other times with the same settings it doesn’t work.
  2. when it can be heard and the IVR asks for a password or any client number, which is entered by pressing keys on the normal desk phone, the signals doesn’t reach asterisk. With IAX it reaches fine.

Any suggestions??


#6

just to double check.
in your sip.conf file, when you goto your extension, you have
nat=yes
set? (similar to example below?). Just double checking because this has bit me a few times.

username=4000
type=friend
secret=12345
qualify=no
port=5060
nat=yes
mailbox=4000@device
host=dynamic
dtmfmode=rfc2833
context=maincontext
canreinvite=no
callerid=device <4000>


#7

checked and the only difference is with qualify that is set to “no” in yours and that is set to “yes” in mine. Last night i forwarded ports from 8000 - 35000 in my adsl router and in my linux accepted all udp traffic from the IP address of my DID provider. The only thing i haven’t done is accepted all (8000-35000) UDP from any address in my router and all UDP from any address (IP) in my linux * box. I am not a security expert so not sure if it poses any major issue in terms of my asterisk being too open to the internet.
Any suggestions? Is there a seperate port that i need to open for the DTMF signalling? I tried changing my rtp.conf to only have range of 20 ports to narrow down and opened same ranged ports in the router and my firewall but same issue. Sometimes i hear IVR menu options and some time i don’t hear but whatever response i pass from my telephone doesn’t reach * box.
thanks


#8

You might try setting up your router as a default route on your asterisk box. sounds like it is a NAT issue. sip doesn’t like NAT


#9

The only reason i need this sip setup is to eliminate a problem i am having with iax DID and trunking.
Here is what i get:

normal phone -> DID(iax)->rings my * box(g729a with digium license and ztdummy)->Termination provider ->terminates (has sound really bad with no errors and calls getting through clean)

Same * box, same internet connection, same router/modem with same g729a following has the sound really clear.

sipura3000 -> extension(registered as a sip user) ->rings my * box(g729a with digium license and ztdummy)->Termination provider ->terminates

all this with only 1 user at the moment. ADSL speed is good with 512.
I see no other reason but the incoming call as SIP instead of IAX. I have re-constructed the asterisk box with fresh install of * (1.2.4) and addons.

Any suggestions? If it comes to the point that i need to take my * box out of the NAT then i will be certainly do it. However, if any tweaking will fix this issue then i’ll be most grateful.

thanks