Start the asterisk1.2 error How can I solve it?


#1

I downlaond asterisk1.2 by cvs and install well have not any error prompt,but when I start asterisk by command :asterisk -vvvc .it’s show me this error prompt ,I install asterisk 1.09 before,and I used centos-2.4.21-37.EL,How can I solve it?
the error is blow:
[format_au.so]Nov 6 04:57:46 WARNING[1221]: loader.c:258 ast_load_resource: /usr/lib/asterisk/modules/format_au.so: undefined symbol: ast_register_file_version
Nov 6 04:57:46 WARNING[1221]: loader.c:440 load_modules: Loading module format_au.so failed!
[root@eshop /]# Ouch … error while writing audio data: : Broken pipe


#2

Did you follow all the instructions about how to build and install from the CVS sources? If you did, did the build process complete properly without any errors?

If the answer to both of those questions is yes, then you should try doing a CVS update again and try building it again. You may have just been unlucky and picked up a version which doesn’t work. That inevitably happens occasionally, as the CVS version is in constant development and when things are being developed they are sure to be broken sometimes.

That may not be the answer to your problem, but it’s the first thing you should try.


#3

I have tried the asterisk1.2 from ftp and cvs and compiled building as instruction,but I meet same status when I start asterisk -vvvc. and I back to asterisk1.0.9 ,same error display,I feel very strange,Where is my fault?


#4

Yes, it is a bit strange.

I’m not sure what Asterisk uses the AU format for, but you could try adding the following line to /etc/asterisk/modules.conf :

noload => format_au.so

and hope that it’s not needed in your setup. This isn’t the best solution to this, but it may fix it for now.

You could also delete that file ( /usr/lib/asterisk/modules/format_au.so) - and probably all the rest of the files in /usr/lib/asterisk - and try re-installing. For some reason you may have a dodgy module file there which doesn’t get overwritten when you install.


#5

agree with WillKemp ! first thing to do is delete/backup /usr/lib/asterisk/modules

did you only download the Asterisk source, or did you get all the others too ? IME, it pays to get the lot !