Speex wideband

I have been trying to use Speex on Asterisk, and the Kiax softphone.

Speex appears to be working with an 8bit sample rate. How do i get it to work at 16bit wideband?

Reading the Speex documentation, I see that you need the --wideband option. I cant see any way of setting this in codec.conf

There doesn’t seem to be much wideband support in Asterisk. I am trying to wean my GF off of Skype, but it sounds so superior :frowning:

If it needs the --wideband option, then you will need to recompile it with the “–wideband” option in the “make” or “configure” statement.

Yes, I tried that, but it failed to make any difference. Having done more reading on the subject, Asterisk doesn’t really support wideband, which is a real shame. When using softphones and a USB headset, the sound quality between Skype and Asterisk, is like night and day. I know there aren’t meny hardware phones out right now that do wideband, but thay are coming. The new low cost AR1688 chipset will have wideband Speex.


freeswitch.org seems to do what I want. Supports GoogleTalk which is an added bonus. Wideband, and C# support?I’m in VOIP heaven! 8) (not tried it yet, so I may eat my words later!!)