[SOLVED]Wanpipe and SS7 work but now no ss7 CLI command

I created an Asterisk box yesterday using the latest versions of the following:

Asterisk 10
Wanpipe driver (for A104 Sangoma 4 port T1/E1 card)

I got everything working correctly with the wanpipe drivers and DAHDI. When I started Asterisk and hit tab, I could see the option for ss7. I restarted Asterisk and now that option is gone for ss7 commands via the CLI. Is there a way for me to check if libss7 is still functional? Any ideas on what could have caused this?

I’m afraid if I can’t get any feedback or figure out the issue that I’ll have to reinstall everything. There’s no way to reinstall a library after Asterisk has already been installed is there? Thanks in advance!

So I’ve solved the issue with the ss7 CLI command disappearing. Module chan_dahdi.so was not initialized properly because I hand edited some values for ss7 in the chan_dahdi.conf file that was autogenerated by /usr/sbin/wancfg_dahdi after I installed the wanpipe drivers. The wancfg_dahdi setup the wanpipe drivers for DAHDI and then allowed for the creation of chan_dahdi.conf via some prompts. My problem there was that ss7 was not a signalling choice. I went into chan_dahdi.conf and hand-edited some parameters but this caused module chan_dahdi.so not to initialize. Removing these additions I made and then loading module chan_dahdi.so solved my original problem.

If anyone has experience getting libss7 to work via chan_dahdi.conf in conjunction with wanpipe (Sangoma A104 card), please let me know. Oh how I wish I had an extra Digium TE420 laying around :smiley: I’ve configured ss7 on a Digium card and it is cake. I’m trying to save some money here though.

please show the chan_dahdi.conf file, and debug info here.

I was able to resolve the issue by regenerating the chan_dahdi.conf file, hand editing the signaling parameters for ss7, and then setting TDMV_DCHAN = 0 in wanpipe1.conf instead of 16. I am still using channel 16 for signaling but wanpipe needs to have D channel set to 0 for some reason. If anyone knows why this is the case, I’d love to hear from you.

I setup the second span on the A104 Sangoma card for ss7 (similar to the process for span 1) and used an E1 crossover cable to loop them together. Both links came up and I was able to use the originate command in the CLI to place a call to a simple extension that played back the “demo-congrats” audio file.

Hope this helps someone down the line. Message me if you need any assistance.