[Solved] [OFF-TOPIC] Yealink TP-28 with 2 or more accounts

I have some Yealink phones (TP-28) that allow settings of up to 6 accounts on the same device.

I’ve set 2 accounts and registered it on Asterisk. I can make and receive calls on both accounts.
I like to use both at the same time, however, when an account is on call, the other account is set as “busy”.
(- Got SIP response 486 “Busy Here” back from MY.YEALINK.IP.ADDR)

Does anyone know if there is a way to force the phone to not answer “busy status” on this situation?

I’ve tried do something like this:
when calls 3906, if it’s busy then calls 3907 (3906 and 3907 are registred on the same phone device)

exten=_3906,1,Dial(SIP/${EXTEN},90) exten=_3906,2,GoToIf($["${DIALSTATUS}"="BUSY"]?3) exten=_3906,3,Dial(SIP/3907),30

but I got:


Can you copy/paste the output of the “sip show peers” from Asterisk CLI?

Do both SIP accounts show as Registered in the status of the IP Phone?

Yes, both (3906 and 3907) are registered .

[code]asterisk*CLI> sip show peers
Name/username Host Dyn Nat ACL Port Status
3900/3900 (Unspecified) D 5060 UNKNOWN
3901/3901 (Unspecified) D 5060 UNKNOWN
3902/3902 (Unspecified) D 5060 UNKNOWN
3903/3903 (Unspecified) D 5060 UNKNOWN
3904/3904 (Unspecified) D 5060 UNKNOWN
3905/3905 D 5060 OK (5 ms)

3906/3906 D 5064 OK (29 ms)
3907/3907 D 5065 OK (24 ms)

9999/9999 (Unspecified) D 5060 UNKNOWN
9 sip peers [Monitored: 3 online, 6 offline Unmonitored: 0 online, 0 offline]

That is very strange. The “Unable to create channel of type ‘SIP’ (cause 20 - Unknown)” usually comes up when a DialPlan sends a call to a SIP peers that is not available (Status=UNKNOWN).

Can you do a “sip set debug ip” in Asterisk CLI, make the test calls, and copy/paste the debug output here?

I’ve solved this in Web Phone Interface:
Phone > Transfer > Call Wait > Enable