[SOLVED] my dyndns gives "no such host"


#1

Hi,

I have something not working anymore. I can’t dial to my dyndns domain frm internal.

Feb 7 01:30:57 WARNING[20091] chan_sip.c: No such host: MYDOMAIN.homedns.org Feb 7 01:30:57 NOTICE[20091] app_dial.c: Unable to create channel of type 'SIP' (cause 3 - No route to destination) Feb 7 01:30:57 VERBOSE[20091] logger.c: == Everyone is busy/congested at this time (1:0/0/1)

and :

# host MYDOMAIN.homedns.org MYDOMAIN.homedns.org has address 80.XXX.YYY.ZZZ

And i’m sure it worked before.
How it possible ?
Is it a new feature in 1.2.4 version that we can’t call ourself ?

[b]Solution : I had to [u]remove srvlookup=yes[/u] from sip.conf, and it works fine now. I don't know what it is used for, and why I added it... [/b]

#2

you haven’t put this behind a different firewall have you ? it’s sounds like a common anti-spoofing policy that prevents NAT’d machines from connecting to an external address that’s port-forwarded.

you could always just add an entry to your local hosts file to see if that gets around it.


#3

The asterisk server in on the firewall, same PC.

And, adding in /etc/hosts can’t change anything, because, this server has its DNS server too, which correctly resolve the dyndns host.

That’s asterisk which doesn’t want it.