[VoIP Trunk] No such host

Hello

I'm trying to add a VoIP trunk to Asterisk, but I'm getting the following warning in the log file if I leave "srvlookup=yes" in sip.conf (OK if I comment it out):

Nov 27 16:40:22 NOTICE[29660] chan_sip.c: – Registration for '087077XXXX@freephonie.net’ timed out, trying again (Attempt #47)
Nov 27 16:40:22 WARNING[29660] chan_sip.c: No such host: freephonie.net
Nov 27 16:40:22 WARNING[29660] chan_sip.c: Probably a DNS error for registration to 087077XXXX@freephonie.net, trying REGISTER again (after 20 seconds)

Any idea what is causing this?

Configuration files and more here: paste.lisp.org/display/30790

Thank you.

Does freephonie.net exist? I tried to ping but there is no response. Must be a typo in your SIP configuration.

No. PING doesn’t answer because it’s filtered by a firewall.

For those struggling with the same error: Make sure your hostname is valid. I made one up “sip.acme.com” which doesn’t actually exist, and this was the cause of the problem. Changing hostname to “sip” solved the issue.

More information can be had by running this:

tethereal -R ‘sip or dns’

Thanks.