[solved] How to play mp3 files on Asterisk 1.8?

Solution: leave off the .mp3, it plays calling it an .sln but works


They wont play on asterisk 1.8

– Executing [998@incomming:3] BackGround(“SIP/777-00000004”, “/path_to_my_file.mp3”) in new stack
[Feb 8 07:13:26] WARNING[9187]: file.c:666 ast_openstream_full: File /path_to_my_file.mp3 does not exist in any format
[Feb 8 07:13:26] WARNING[9187]: file.c:957 ast_streamfile: Unable to open /path_to_my_file.mp3 (format 0x4 (ulaw)): No such file or directory
[Feb 8 07:13:26] WARNING[9187]: pbx.c:10336 pbx_builtin_background: ast_streamfile failed on SIP/777-00000004 for /path_to_my_file.mp3
– Auto fallthrough, channel ‘SIP/777-00000004’ status is ‘UNKNOWN’

In make menuselect, it is enabled:
[*] format_mp3

The module exists:

root@grumpybugs:/usr/src/asterisk-1.8.32.3# ls -l /usr/lib/asterisk/modules/format_mp3.so
-rwxr-xr-x 1 root root 388015 Feb 8 03:01 /usr/lib/asterisk/modules/format_mp3.so

Hm?

When playing a file don’t include the extension name, just the file name