[solved] ERROR: __ASTERISK_SBIN_DIR__/asterisk not found


This was produced by a yum installed asterisk,
“yum install asterisk”

It needed the “make config” command or equivalent.

On a new install, attempting to restart the service generates this error:

ERROR: ASTERISK_SBIN_DIR/asterisk not found

If the service isn’t running, try typing

/usr/sbin/asterisk -cvvvvvvvvvv

Which will kick off Asterisk in stand alone mode. See if it starts then.

If it does, you may have a problem with the /etc/init.d/asterisk file

If it doesn’t you’ll have a heap of output to work with :smile:

Good luck

The error is indeed in /etc/init.d/asterisk.

The line AST_SBIN=__ASTERISK_SBIN_DIR__ appear in the script when you copy it from the contribs directory. If you edit the script and change the word “ASTERISK_SBIN_DIR” to “/usr/sbin” then the script will work.

This feels wrong to me. Was there supposed to be a configure macro that changes this value?

I note that this is in the tarball for The previous version I built was which had the correct directory name at this place in the script.

I imagine you are supposed to do make configs

That option is new to me and its not mentioned in README which is where I would expect to find it. It is not mentioned in any of the notices at the end of the other make commands which I find are a great way to get this information across.

I tried it but got the “nothing to do” error. Then I read through the Makefile and realised it is “make config”, which needs to be run as root as it installs files in sacred places.

Thanks for your help.