[SOLVED] Dial cmd 'H' & 'h' options with 'g'


#1

I am trying to get the ‘H’ and ‘h’ option to work with the ‘g’ option, in the Dial cmd in order to allow a caller/callee to dial ‘*’ to disconnect from the conversation and continue in the dialplan.

But, whenever I hit the ‘*’ key from either phone, I get this in my CLI:

[quote=“CLI”]-- Attempting native bridge of SIP/3002-c240 and SIP/3001-ddf0
– Attempting native bridge of SIP/3002-c240 and SIP/3001-ddf0[/quote]

Both phones are configured for RFC2833 DTMF and work fine for other apps such as voicemail.

[quote=“extensions.ael”]context test_hangup_loop {
s => {
Dial(SIP/3001|30|Hhg);
goto test_hangup_loop|s|1;
};
};[/quote]

If the called party hangs up the ‘g’ option works fine as it dials again. Anyone had luck in getting the ‘H’/‘h’ options to work?


#2

I was able to get this working using the /etc/asterisk/features.conf setting:

[quote=“features.conf”][featuremap]
blindxfer => *0 ; Blind transfer
disconnect => *1 ; Disconnect
automon => *2 ; One Touch Record
atxfer => *3 ; Attended transfer[/quote]

By pressing ‘1’. This explains why I could not get '’ to work as when the features.conf settings are enabled Asterisk does not take action simply on ‘’ as it appears to be waiting for an additional digit. So, if I deleted the ‘disconnect’ option out of features.conf the '’ works as expected.

So it is an either/or scenario, either use the features.conf or ‘H’/‘h’ options.