[SOLVED] asterisk runs but not rasterisk

Currently, my asterisk which is running on a LaFonera WiFi router is working after I applied a simple hack to fix some problem. However, I sure would like to get some feedbacks from readers here to get this problem fixed in a more proper/normal way.

Here is what I have done:
[ol][li]I downloaded and successfully compiled OpenWRT SVN trunk with asterisk v1.4.17.[/li]
[li]I flashed my LaFonera 2100 WiFi router with this newly compile OpenWRT firmware + asterisk v1.4.17.[/li]
[li]I managed to configure the asterisk with some VoIP lines, GTalk, and some extensions. They are all working fine.[/li][/ol]
My problem is as follows:
[ol][li]If I configure my asterisk to run during the boot time using the /etc/init.d/asterisk scripts file, my asterisk will only run with three processes. Any further attempt to launch rasterisk or asterisk -r, will get an error message saying Unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?) At this stage, none of my VoIP lines nor extensions get registered as if they all are dead. No GTalk neither. See below:

[code]root@Fonerisk:~# /etc/init.d/asterisk start
root@Fonerisk:~# ps
PID Uid VSZ Stat Command
1 root 1664 S init
2 root SW< [kthreadd]
3 root SW< [ksoftirqd/0]
4 root SW< [events/0]
5 root SW< [khelper]
20 root SW< [kblockd/0]
40 root SW [pdflush]
41 root SW [pdflush]
42 root SW< [kswapd0]
43 root SW< [aio/0]
56 root SW< [mtdblockd]
188 root SWN [jffs2_gcd_mtd3]
202 root 1664 S logger -s -p 6 -t
203 root 1664 S init
210 root 1676 S syslogd -C16
212 root 1660 S klogd
220 root 752 S /sbin/hotplug2 --override --persistent --max-children
489 root 1660 S crond -c /etc/crontabs
493 root 1172 S /usr/sbin/dropbear -p 22
499 root 1660 S httpd -p 80 -h /www -r OpenWrt
516 nobody 888 S /usr/sbin/dnsmasq -K -D -y -Z -b -E -s lan -S /lan/ -
539 root 1228 S /usr/sbin/dropbear -p 22
540 root 1676 S -ash
543 root 1228 S /usr/sbin/dropbear -p 22
544 root 1668 S -ash
568 root 2600 S /usr/sbin/asterisk -C /etc/asterisk/asterisk.conf
569 root 2600 S /usr/sbin/asterisk -C /etc/asterisk/asterisk.conf
570 root 2600 S /usr/sbin/asterisk -C /etc/asterisk/asterisk.conf
571 root 1664 R ps
root@Fonerisk:~# rasterisk
Asterisk 1.4.17, Copyright © 1999 - 2007 Digium, Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?)[/code][/li]
[li]If I edit the /etc/default/asterisk scripts file to include a -v, then /etc/init.d/asterisk start will return twenty-one and/or more asterisk processes. At this stage, rasterisk will gives me the asterisk CLI and all my VoIP lines, GTalks, and extensions are normally working with incoming/outgoing calls. See below:

[code]root@Fonerisk:~# ps
PID Uid VSZ Stat Command
1 root 1664 S init
2 root SW< [kthreadd]
3 root SW< [ksoftirqd/0]
4 root SW< [events/0]
5 root SW< [khelper]
20 root SW< [kblockd/0]
40 root SW [pdflush]
41 root SW [pdflush]
42 root DW< [kswapd0]
43 root SW< [aio/0]
56 root SW< [mtdblockd]
188 root SWN [jffs2_gcd_mtd3]
202 root 1664 S logger -s -p 6 -t
203 root 1664 S init
210 root 1676 S syslogd -C16
212 root 1660 S klogd
220 root 752 S /sbin/hotplug2 --override --persistent --max-children
484 root 9384 R /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
489 root 1660 S crond -c /etc/crontabs
493 root 1172 S /usr/sbin/dropbear -p 22
499 root 1660 S httpd -p 80 -h /www -r OpenWrt
502 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
505 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
507 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
512 root 1228 R /usr/sbin/dropbear -p 22
517 nobody 888 S /usr/sbin/dnsmasq -K -D -y -Z -b -E -s lan -S /lan/ -
522 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
523 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
524 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
525 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
526 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
527 root 1668 S -ash
530 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
531 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
532 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
533 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
534 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
535 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
536 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
537 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
538 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
539 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
540 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
541 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
544 root 1228 S /usr/sbin/dropbear -p 22
545 root 1668 S -ash
547 root 2604 S rasterisk
548 root 9384 S /usr/sbin/asterisk -vC /etc/asterisk/asterisk.conf
549 root 1664 R ps
root@Fonerisk:~# rasterisk
Asterisk 1.4.17, Copyright © 1999 - 2007 Digium, Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Connected to Asterisk 1.4.17 currently running on Fonerisk (pid = 484)
Verbosity is at least 1
Fonerisk*CLI>[/code][/li][/ol]
Although this quick hack/fix works, I am here seeking for a more subtle and/or better way to get this problem fixed, let alone wanting to know what causes the problem. So, I will appreciate if anyone out here can help

If the asterisk service is not running, you can type “asterisk” to start the service, or “asterisk -c” to start the service with the console, or “asterisk -cvvv” to start the service with the console and a verbosity level of 3, etc.

If you typed “asterisk” (you now have the service running), you can connect to it later with the command “asterisk -r” or “asterisk -rvvv”, etc, depending on verbosity (I prefer a verbosity level of 43).

If you type “asterisk -c”, you must kill the process in order to get back to your original terminal screen (unless you switch to another terminal).

you get this message
Unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?)
because you are trying to reconnect (asterisk -r) to an asterisk service that isnt running. Start the service by typing “asterisk”

edit - i got so excited i posted twice…can an admin delete my this post please?

You don’t seem to understand my situation. My asterisk can start automatically as a service from an init boot scripts file through a reboot and/or manually from executing the /etc/init.d/asterisk start scripts file; however, the started service will not start normally to register my VoIP lines. This will only start three asterisk processes and they don’t seem to do anything. Trying to remotely connect using rasterisk and/or asterisk -r will get an error message saying Unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?), let alone all services are dead. If I modify the contents of the /etc/default/asterisk file:

[code]## startup options for /etc/init.d/asterisk

ENABLE_ASTERISK=“yes”
OPTIONS="-C /etc/asterisk/asterisk.conf"[/code]
to contain a -v switch like this:

[code]## startup options for /etc/init.d/asterisk

ENABLE_ASTERISK=“yes”
OPTIONS="-vC /etc/asterisk/asterisk.conf"[/code]
my asterisk will run just find and all my VoIP lines, including GTalk lines, will register to serve all incoming/outgoing calls without a single problem. What I want to know is why a -v switch is needed and how to fix this problem.

You are running asterisk on a platform it was not targeted for. I do it too, only on a netgear NSLU2 (aka “SLUG”).

When you are running an an untargeted platform, expect it to be a bit rough around the edges. That is just the way it works. The basic linux install on the slug has a few quirks as well.

On the plus side, you seem to have hit on what it takes to make it work.

You are fighting the numbers, figure there is one person doing what you are doing for perhaps every 10,000 or more i386 installs of asterisk on PC hardware. There is never going to be the same level of support until the numbers come up. We are the odd men out.

I just can’t dispute that. :smiley:

So, it looks like no asterisk experts here seem to know why a -v switch is needed to run asterisk properly on an embedded Linux device. :frowning:

This problem has been resolved by compiling asterisk against older version of uClibc-0.9.28.2 instead of uClibc-0.9.29.