[SOLVED]Asterisk Realtime PJSIP show endpoints like Unknow

I have an Asterisk server running with PJSIP protocol and after turn on the Realtime I have problems with the registration of the endpoints.

Bellow is the log when the system register the endpoint and imediatelly show as Unknown the device:

  == Contact 6002/sip:6002@ has been deleted
    -- Removed contact 'sip:6002@' from AOR '6002' due to request
  == Contact 6002/sip:6002@ has been created
    -- Added contact 'sip:6002@' to AOR '6002' with expiration of 3600 seconds
    -- Contact 6002/sip:6002@ is now Unknown.  RTT: 0.000 msec

My network has NAT allowed and the qualify_timeout was defined to 10.

ip-172-31-12-250*CLI> pjsip show contacts

  Contact:  <Aor/ContactUri..............................> <Hash....> <Status> <RTT(ms)..>

  Contact:  6001/sip:6001@;rinstance= b258b9ce53 Unknown         nan
  Contact:  6002/sip:6002@            5955f33499 Unknown         nan
  Contact:  6002/sip:6002@            e0b70c1001 Unknown         nan
  Contact:  6002/sip:6002@            99ebd25ebf Unknown         nan
  Contact:  6003/sip:6003@            aad42bada3 Unknown         nan
  Contact:  6003/sip:6003@            ac2a7826fa Unknown         nan

You need to also ensure that the “qualify_frequency” option is set, or else qualify support will not be enabled.

1 Like

just put and solved the problem, know the endpoints show as available.

thank you so much jcolp.