SOLVED: Asterisk MixMonitor not recording queue calls

In my Asterisk 1.8 setup, MixMonitor() in the dial plan successfully records calls without issue.

However for queue calls, while a recording file is generated and the log shows that MixMonitor() is recording, however the files are tiny and contain no audio.

This is my queue:

member => SIP/extension123

(I also have directmedia=no set for the device in sip.conf)

I have also tried changing the monitor type to “Monitor” and the format to “wav”, with the same result. I have also tried adding local channels as queue members and recording from the local channel in the dial plan instead of using the queue’s recording and I get the same result (even though when dialing the local channel extension directly the recording works fine).

Any help would be appreciated.

Update: I am trying the same thing now on Asterisk 11.7 and experiencing the same issue

Figured it out: calls were being passed to the queue via a local channel. Apparently you need to add “\n” to the local channel call to keep it from being “optimized away”.

For example:


Source: … rev=197897