Small glitch every 20 sec!


I have installed Asterisk on two Fedora 5 systems.
On the first machine everything is OK, very good sound.

But, on the another machine (nearly exactly a copy of the first), when making an outgoing call, the sound is “dipping” / dissapearing approx 300-500ms every 20 second!
When running top -d1 I see that it is exactly the same 20 seconds everytime, call after call (xx:04, xx:24, xx:44 and so on).

For testing I’m calling a land-based line (PSTN) and sets the call on hold to listen to MoH. I’ve also tested putting the called (PSTN) phone near a radio and listen in the IP-phone. Then the reverse, putting the IP-phone at the radio and listen in the PSTN-phone.
The 20-sec glitch appears in the MoH and outgoing radio-sound (IP -> PSTN), but not the opposite.

I’ve reinstalled the 2:nd machine 4-5 times now, testing Fedora 6, Fedora 5, Asterisk 1.2.13, 1.2.15 and 1.2.16.
Changed the processor from Celeron 2GHz to P4 Dual Core 3GHz, upgraded memory to 1GB.
I’ve compared every running service on the machines, exactly the same.

I’m using Thirdlane Multi Tenant PBX Manager to make the .conf-files on both machines.
The same .conf-files on both machines.

Anyone heard about this before, or can guide me in some direction?

I’ve installed a dozen Asterisk / AAH / Trixbox on Fedora 4, Fedora 5, CentOS without any problems…

Regards - Tomas

What I lack in knowledge, I try to make up for with my engineering training. I will try to isolate the problem to the point where I know what I have to solve. If I had two nearly identical boxes, one worked, one didn’t, then I would start swapping parts.

I would take the hard drive from the working computer, and put it in the lemon.

Try swapping your pstn card to your working system. Maybe it is your card.

Maybe you have a mobo issue.

If you have done many installs that work, I am suspect you have hardware issue.

Thanks for a quick reply.
The boxes hardware isn’t equal, so it wouldn’t work swapping hard drives. When I said nearly identical I meant how I’ve installed the software.

I’ve tried to install a third box, same problem here. 20 sec glitch is on the third machine also.

The connection to PSTN isn’t in the machine, but througt a VoIP-provider. Same provider and telephone number on all boxes (not at the same time, of course).
I’ve tried different VoIP providers, tried to move the boxes to other locations / ISP’s… no luck…

It is no problem when dialing internally.
It doesn’t matter if I call in or out to/from PSTN, same glitch here

Maybe I should try my luck on some Fedora forum, I want to know if something is happening every 20 secs in a Fedora install.
I thought it could be something in Asterisk, but…

Please help!

Regards - Tomas

is there any way for you to tell if other services are being impacted every 20 seconds? it sounds to me like some kind of high priority interrupt or system software is taking over the CPU for a brief time.

I was thinking the same thing. I should ask this on some Fedora forums out there…
The strange thing is that it’s only on PSTN calls, not internal VoIP!

Hmmm, are internal VOIP calls SIP? If so, and you have reinvite set to true, the audio stream will never hit the asterisk box, so you might not notice…

Yes, internal calls are SIP. I tried to remove reinvite, still the same issue on outbound, but 100% OK internally…

I have a clue!
I just rebooted the machine after uninstalling a lot of RPM’s that isn’t in the first machine.

When waiting for it to come alive I ran a ping to the machine. When it started to reply, I noticed that some of the ping times was a lot higher than the others (from 4 to 150 ms). When I started to count, the long ping times was every 20 sec…
Maked a PSTN-call, put on hold, listened to the music and ran a ping… the 100ms reply times was EXACTLY when I could hear the dip in the sound…

I’ve had a bad feeling about the network the machine is running on. But… I’ve got an ATA-box directly connected to the VoIP-provider. This line has always worked great. Is Asterisk traffic more sensitive to bad networks than an ATA-box??

And another thing… Why just on PSTN-traffic and not between my SIP-phones and the server (I’m sitting 70 kilometers away from the server).

One thing is for certain anyway… I’m getting really tired of this MoH. James Blunt - Goodbye My Lover and Orinoco Flow by Enya… :S

Regards - Tomas

Could be different latency handling policies. Not sure if you can fine tune this in Asterisk, but >100ms delay is REALLY bad for most applications. (Have you tried to ping your ATA?)

Just a wild guess: since your PSTN is through a VoIP provider, it could be imcompatible latency handling policies. Is the ATA provided or configured by the provider?