Issues with echo / repeated audio

Hi there,

For a while now we’ve had the strangest problem with audio on calls going through the Asterisk box. Basically, it’s about repeated audio. Not in a classic “echoing” way, but rather more of a delay that occurs periodically.

Whenever this occurs, the audio of the external party (the party calling in to the Asterisk box) is played, then repeated a fragment of time (like 0.5-2 seconds) later. It might occur midway in a conversation, rarely from the start.

Our setup is purely SIP/IAX based, and the external party has never complained about sound issues, so I take it that this only applies to users on our end.

At first I thought that this might be issues with our provider, so I asked them to supply us with calls from another trunk, which they did. But then I even found that there were similar sound issues when calling in to a MOH-extension(!).

Our setup is 4x CISCO 7960s, SIP-firmware v. 8.2, and the the PBX, which is a Celeron 2.4, 512 MB RAM running Fedora Core 5. The Asterisk box itself is running the 1.2-branch, although I have been frequently updating this through SVN, so it really shouldn’t be related to just one particular 1.2.x build.

I doubt this is related to our internal network, as I have taken the effort replacing both the switch and the router separating the PBX from the rest of our office network without results. For the record, I have two of these Celeron computers laying around, and the issue persists on both machines.

I am getting lost here. I am left with the possible theories that it might be either:

  1. The OS itself having issues with the hardware (the OS is fairly recent, but we had similar issues with the Centos 4.x branch before installing Fedora last fall)
  2. An Asterisk-related bug, or
  3. A bug relating to the Cisco phones.

I wish I could exclude the number three, but to be honest, this problem has been going on for so long I can’t recall if I ever was able to recreate the issue using Xten or other softphones. Since it’s very periodical, it’s really hard to debug using the elimination method.

I should add: If I put the call on hold and then pick it up again, magically, the echo is gone - at least for a while…

Any feedback would be appreciated.


Run TOP on the box when the echo happens (all phones have echo it is the lag which allows us to notice it).

And not to get into Linux OS war here but I have found Centos to have less issue with echo…

What codec do you use???

Hi there, and thanks for answering.

What should I expect to see from top? I know for sure there’s no load issues on the box (load is in general 0.01) and the audio issues might arise when there’s only one active call.

We have tried using another provider too, but same issues. I’d add this as well:

Tried to listen to a MOH extension from a remote extension (over a decent ADSL connection) and the problem occoured even then. So my thought is that this could be one of three:

  1. The asterisk box itself
  2. The Cisco 8.x firmware (have a mix of Cisco 7960s running 8.2 and 8.6), or
  3. The ADSL 2+ line of which the asterisk box is connected through.

I might add this as well, although I don’t know if it’s somehow related:

Problem 1: We use the chanspy-application, and I’ve also noted that sometimes when listening in on a call all sounds fine at the start, but then as time proceeds one can start to notice an increasing delay in the audio stream, so that after a while one might actually hear the words spoken several seconds later than when they were actually said. This is taking place on local extensions.

Problem 2: I’ve also noticed that when answering some calls, audio from the calling party does not pass through for the first few seconds, basically causing the first few seconds of the call to be clipped away. Happens when answeing calls from queue, and the problem arises randomly.

I’d assume, however, that the calling party hear us, as usually the person at the other end is well into the conversation when audio is finally passed through to us.

Hardware: The Celeron was replaced by a P4 2.8 with 512 MB RAM, Centos 4.3. No difference.

OK here may be the issue ADSL2 is not a good choice for VOIP

You need to spaek with your telco ask if the line is a ADSL2 Annex L A.K.A. RE-ADSL2 line if so that is your problem for sure

Adsl2 does some funky stuff to “adjust” the line and what you may be hearing is the line “adjusting” the packets to increase / decrease the speed

because the extra power on the lower frequencies might cause problems for existing services due to crosstalk which is what you are talikning about I think.

Where did you put the filter(s)

The easy test is to setup the box on a T-1 or Cable modem.

But I am sure you will find that what I am point you to is the issue…

Hello Hubba, and thanks for the very informative reply!

Assuming you’re talking about the modulation here? I am not an ADSL expert, but from logging into the modem, I find the modulation to be the following:

G.992.5 Annex B

Could this be cause of the issue then, and is there anything I can do (e.g. downgrading to regular ADSL) to solve the problem? Last resort, I can always have fiber installed at the office, but that’s about twice as expensive as getting a T1.

EDIT: What filter are you referring to? If you are referring to the split between the ADSL and the phone line, this split is set up as per the telco’s instructions, meaning that the signal splitting occours before any phone devices are connected to the line (input to the splitter is the line from the telco, output is the ADSL modem and the ISDN GT box).

Bjorn … riber_Line

Yes that is ADSL2 Well in some cases you can get PLAIN dsl which is why they sold u adsl2 (adsl2 extends the dslam past the limit)

It could very well be it (have seen it three times) folks chased Crosstalk all over the place, in each case when the system was setup behind a different service the crosstalk was not present.

Yes that filter.