SIP Registration with @password

Hai Everyone,

I have SIP Trunk from Operator which have the userid and password. And need to register the same in my asterisk 16 server. But the problem is that the SIP password is coming with @.

User Id: testid
Password:test@123
Host:10.10.10.10

And How i can register this SIP in my asterisk server?

Which SIP channel driver are you using? How did you try configuring it? What happened?

am using the channel driven chan_sip

And i have added the sip.conf register file as below

User Id: testid
Password:test@123
Host:10.10.10.10

register =>testid:test@123@10.10.10.10:5060/123456

but as the password have @ with in that am getting the forbidden response from my operator. Hence is there any option where i can register the SIP with @password.

User Id and Password are not valid sip.conf options.
: is not a valid delimiter beween an option and a value.
Host is nromally host, although it is possible that it is checked case insensitively.

@david551
the problem is with password. If i change the password with out @ then its working fine. Only the problem when i gave the password @.

Whilst it is possible that Asterisk has problems with secrets containing ā€œ@ā€, you need to provide a sip.conf file that is valid apart from that before it is worth thinking about.

Also chan_sip is only community supported, so, if there is a bug, it may never get fixed.

Iā€™m wondering if your invaid sip.conf is really a copy of a GUI screen. In that case, your problem is likely to be in the GUI. No GUIs are supported here.

There no GUI in this. And SIP is getting registered with out @ in the password. Mostly Asterisk has problems with secrets containing ā€œ@ā€,

Have you tried escaping the @ with a \ infront of it?

Nope i have not tried that ā€¦ by escaping @ with a \ , then in my password also @ will be removed right ?

Iā€™d try callbackextension rather than register.

Also, Iā€™m not sure that you need the secret in register, if it is in the peer entry, but I could be wrong.

1 Like

Escaping the character will not remove it, it tells Asterisk to not parse that character.