SIP, PJSIP and WebRTC at this same time

Hi,

I need to use sip pjsip(webrtc) at this same time but Asterisk tell me is pasword is wrong when SIP and PJSIP is enable at this same time. When I disable chan_sip all working well. Where could be issue ?

Trying to bind chan_sip and chan_pjsip to the same port. Only one of them will succeed.

I dont think so. I bind chan_sip to :5060 and pjsip to :5080. And situation is I can register by sip account but when I try via pjsip then Asterisk say wrong password. If I load res_pjsip_transport_websocket.so then I can via pjsip but I cant loggin as sip account

Ok, more details.

After that, when I unload chan_sip then load res_pjsip_transport_websocket.so and load previously unloaded chan_sip. Problem solved. But question is. How to properly configure modules.conf ?

The sip.conf configuration file has an option named “websocket_enabled” to disable its Websocket (and thus WebRTC) support. Setting it to “no” will disable it, allowing PJSIP to be used for WebRTC instead.

Have you defined the user for pjsip as well as chan_sip? They do not share endpoint configuration, meaning you need to define the username and password for both modules.

I know the question seems basic, but you did not specify if the user works with chan_sip if you disable pjsip AND it also works with pjsip If you disable chan_sip

pjsip and chan_sip has different credentials, now it works well until i restart asterisk. after that i need to unload chan_sip, load res_pjsip_transport_websocket and load chan_sip. then it all works well

i cant find this option in my sip.conf file

If you manually list the modules you want loaded, in your modules.conf, you can change the order in which Asterisk will load them. This might solve the problem of having to unload and reload the module.

If the option is not there, just add it… There’s an example in the sample config supplied with the Asterisk source.