SIP extn calls work but NO sound files are playing :(

I have a very strange problem and I have been slaving over it for the past day with no success. Hopefully somebody out there can help.

The problem:

I can call other SIP extensions however if I set up a playback or music on hold for example nothing is heard on the SIP phone.

If I go into voicemail I have the same problem, no sound at all. The echo test displays no sound either and doesn’t work.

When a sound is playing the console shows it playing the file without any errors, so it appears Asterisks thinks there is no problem at all.

I have ruled out most of the obvious as I can call another SIP device without any issues so it has to be something on the operating system level.

The set up:

I have tried Asterisk, Asterisk 1.4.22 and even (as this old version worked on my Windows box that I tried it out on to rule out any problems with my sip devices).

The OS is CentOS 5.2 hosted at a data centre and the firewall ports required to make it work are open (as per the wiki info).

Possible reasons:

This is a dedicated Dell server with no emulation or anything obvious. It is fairly powerful but HAS NO SOUND CARD. I am thinking maybe that is why but I can’t think why because correct me if I am wrong the soundcard is not used at all on the server??

I am also thinking maybe it’s a port on the firewall that I forgot to open but the fact that I can make and receive calls to other SIP extensions would appear to rule this out. Plus I opened the ports required by the docs (yes I actually have read the readme files and docs :smiley: )

I have NO zapatel or other telephony cards in the box, I am using this to take calls from my SIP phone company and also route calls via it for a charity in Dublin to hopefully save them money. All the issues I saw on the web seemed to be related to this area of things, but as I don’t have any perhaps I need to configure it in some way to play sounds to SIP?? that doesn’t seem right to me tho.

Thanks for your attention:

So if you could help me out that would be great, it is for a charity that support young people at risk to suicide in Ireland by providing a phone service ran by other young people so it would be great if I could get it working for them.

Many thanks

Ok I should have remembered all those classes that I did at college when I studied SIP for my Masters in mobility!

The solution is - I was worried about opening so many ports on my server so I set it to only cover 10 ports. The server was coming back at random default ports between 10000 and 20000 hehe only I had only the first 10 open :smile:

So the server was playing the files but the conversation was not really happening as the port was blocked. I don’t know why it didn’t detect this but it didn’t so no errors were there. Perhaps it might be possible to do a check on this in future releases of the product when in Debug mode?

Anyhow if anybody else has the problem just set:


in your rtp.conf file in the etc directory of asterisk, where xxxxx is the final number of ports you have opened.

I hope this helps somebody out there :smile:
Love and Light!
Dublin, Ireland

ps-has anybody ever thought about doing Irish voices for Asterisk? in the Irish language (Gaeilge) and Hybern English (Irish accents)? I’d be happy to contribute!