SIP/2.0 480 Temporarily Unavailable

I have been getting following error,

<— SIP read from UDP:10.200.57.112:5060 —>
SIP/2.0 480 Temporarily Unavailable
Via: SIP/2.0/UDP 10.200.95.50:5060;branch=z9hG4bK72f816d7;rport=5060
Call-ID: 51edf870642d53ca2244c6ce6c961993@10.200.95.50:5060
From: sip:04232590040@10.200.95.50;tag=as534051eb
To: sip:03325499011@10.200.57.112:5060;tag=dvxadldd
CSeq: 102 INVITE
Warning: 399 03125.00493.B.005.404.228.0.22.03204.00000000.1073807555 “Incoming trunk group status is fault”
Content-Length: 0

<------------->
— (8 headers 0 lines) —
Transmitting (NAT) to 10.200.57.112:5060:
ACK sip:03325499011@10.200.57.112:5060 SIP/2.0
Via: SIP/2.0/UDP 10.200.95.50:5060;branch=z9hG4bK72f816d7;rport
Max-Forwards: 70
From: sip:04232590040@10.200.95.50;tag=as534051eb
To: sip:03325499011@10.200.57.112:5060;tag=dvxadldd
Contact: sip:04232590040@10.200.95.50:5060
Call-ID: 51edf870642d53ca2244c6ce6c961993@10.200.95.50:5060
CSeq: 102 ACK
User-Agent: Asterisk PBX 13.18.2
Content-Length: 0


-- SIP/04232590040-0000001d redirecting info has changed, passing it to SIP/000-0000001c
-- SIP/04232590040-0000001d is busy

My sip.conf settings are,

[04232590040]
type=friend
context=SIP_GATEWAY
host=10.200.57.112
allow=all
insecure=port,invite
nat=yes
relaxdtmf = yes
qualify=yes
progressinband = yes
port=5060
canreinvite=no
dtmfmode=auto
trustrpid=yes
;sendrpid=yes

The response came from the remote side, and they attached:

Warning: 399 03125.00493.B.005.404.228.0.22.03204.00000000.1073807555 “Incoming trunk group status is fault”

I know but service provider says it is the issue from client side. They are saying remote side is ok.

Inbound calls are being received successfully without any error.

But outbound calls getting rejected.

They are definitely saying inbound trunk, which means the trunk from you, but, as this is not a standard SIP message, it is not easy to say why they think it is faulty.

Taken at face value, I would say that they already thought your trunk was down before you tried to issue the INVITE.

If they won’t help you, do you know what they use to implement their service. Maybe you can find some documentation that explains what the numbers in the message mean.

Wildly guessing, you might be marked as down because you haven’t registered (many systems require that for calls to be accepted, even though SIP doesn’t), or that they’ve done a connectivity test, e.g. with OPTIONS, that has failed.

Is there any reason why you are using the, effectively unsupported chan_sip, and a definitely unsupported version of Asterisk?

Where did you get your sip.conf settings from? They show most of the typical bad practice (low security, obsolete options, ineffective options, and unneeded workarounds) that are common with provider supplied configurations. However, I don’t think any of those are causing your problem.

These configuration are provided by service provider.

Since it is private link not on public network that is why authentication is not an issue.

The trunk is up and online that is why inbound calls are being received,

IAC*CLI> sip show peers
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
000/000 192.168.1.38 D No No 62196 OK (108 ms)
001/001 (Unspecified) D No No 0 UNKNOWN
002/002 (Unspecified) D No No 0 UNKNOWN
003/003 (Unspecified) D No No 0 UNKNOWN
004/004 (Unspecified) D No No 0 UNKNOWN
005/005 (Unspecified) D No No 0 UNKNOWN
04232590040/04232590040 10.200.57.112 Yes Yes 5060 OK (43 ms)
101/101 (Unspecified) D No No 0 UNKNOWN

If any other setting can be helpful to change please let me know.

Note that allow=all, definitely results in excessively large INVITE requests, and at least in some circumstances results in failures, although I seem to remember that it is the Asterisk end that fails.

If tried following settings.

[04232590040]
type=friend
context=SIP_GATEWAY
host=10.200.57.112
disallow=all
allow=ulaw
allow=alaw
allow=gsm
insecure=port,invite
nat=yes
relaxdtmf = yes
qualify=yes
progressinband = yes
port=5060
canreinvite=no
dtmfmode=auto
trustrpid=yes
;sendrpid=yes

but still issue is same.

The provider is saying it is in a fault state for calls that are inbound to them.

You need the equivalent information to sip show peers from their system, as it is their system that thinks there is a problem.

However, in the mean time, I would definitely provide a sensible, short, list of allowed codecs, and disallow all others.

Already applied the setting.

Sending to 10.200.57.112:5060 (NAT)
Looking for s in default (domain 10.200.95.50)

<— Transmitting (NAT) to 10.200.57.112:5060 —>
SIP/2.0 404 Not Found
Via: SIP/2.0/UDP 10.200.57.112:5060;branch=z9hG4bKqqv8a7g5sa7rm74lssg464sq7;Role=3;Hpt=8e58_16;pth=0;X-HwDim=4;received=10.200.57.112;rport=5060
From: sip:SBC@10.200.57.112;tag=aevg78mg
To: sip:10.200.95.50;tag=as096c4b3c
Call-ID: gaamv88vs9svqq761as41rmg1va4vgg5@112.57.200.10
CSeq: 1 OPTIONS
Server: Asterisk PBX 13.18.2
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY, INFO, PUBLISH, MESSAGE
Supported: replaces, timer
Accept: application/sdp
Content-Length: 0

What is SBC? Why is in error

Session Border Controller

A 404 still confirms that you are reachable and Asterisk would accept that. However, I suppose it is possible that they only intended for phones, not PABXes, and insist on an OK. However, I think that would stop them sending to you.

This fixed my issue. Service provider has incorporated a heart beat. I added following dialplan,

[default]
exten => s,1,NoOp( DEFAULT context )

It resolved SBC error. Then I tried Outbound and bingo, it worked.

Thanks for your hint and kind support.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.