Sip trunk outgoing call problem


#1

Hey again,

I have a sip trunk subscription and I have the following config:
extensions.conf

exten => _9X.,1,Dial(SIP/${EXTEN:1}@<sip-trunk-ip>)
[from-trunk]
exten => _X!,n,GoTo(my-ivr,s,1)
exten => _X!,n,Hangup

the problem is:
incoming connections all connect to my ivr and they are handling as they should
outgoing connections (9X.) gives this errors:

-- Executing [8<dialed-number>@X:1] Dial("SIP/Y", "SIP/<dialed-number>@<sip-trunk-ip>") in new stack
== Using SIP RTP CoS mark 5
-- Called SIP/<dialed-number>@<sip-trunk-ip>
-- Got SIP response 480 "Temporarily Unavailable" back from <sip-trunk-ip>:5060
-- SIP/<sip-trunk-ip>-00003d9a is circuit-busy
== Everyone is busy/congested at this time (1:0/1/0)

in “core show channels” I see nothing weird, but in “sip show channels” I see 16 occurrences of the following:

<sip-trunk-ip>   (None)           Call ID  (nothing)        No       Rx: OPTIONS                <guest>

#2

The remote side responded with 480 “Temporarily Unavailable”. Why that is you would likely have to ask them, or if you provided the configuration in sip.conf we may be able to answer as well.


#3

Which part of sip.conf you need. Because for my outgoing calls, I don’t have anything in my sip.conf.

The SIP provider has not been answering yet. Trying to get them to respond.


#4

How are you expected to authenticate with them? Not having a peer configured for them means that only global settings are in use.


#5
[sip-trunk]
host=<sip-trunk-ip>
type=friend
context=from-trunk
insecure=port,invite
dtmfmode=RFC2833
qualify=yes
relaxdtmf=yes
directmedia=no

The incoming calls part. For outgoing, I don’t need authentication.


#6

Then you would need to talk to the provider. They are the one rejecting the call.


#7

could the stuck channels in ‘sip show channels’ cause it?
How can I terminate them so that the remote peer terminates them too?


#8

Those aren’t stuck calls. They are the resulting of sending an OPTIONS request to check that the remote side is available and to check latency. It is enabled using the “qualify=yes” line you have in your configuration.


#9

Thanks a lot. I have many calls on my asterisk and can’t easily check the sip logs. I couldn’t find out about it without your help.