'service asterisk start' fails to start asterisk

I have a fresh install of Asterisk 1.8 running on CentOS 6.4. I built Asterisk with configure;make;make install;make samples;make config.

When I issue the command ‘service asterisk start’ I am unable to connect to asterisk using ‘asterisk -rvvv’ and am given the following output:

[root@admin-b ~]# asterisk -rvvv
Asterisk 1.8.15-cert2, Copyright © 1999 - 2012 Digium, Inc. and others.
Created by Mark Spencer markster@digium.com
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

== Parsing ‘/etc/asterisk/asterisk.conf’: == Found
== Parsing ‘/etc/asterisk/extconfig.conf’: == Found
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
[root@admin-b ~]#

Interestingly enough, ‘service asterisk status’ tells me asterisk is running. If I run ‘service asterisk stop’ then running ‘service asterisk status’ will report that asterisk is now stopped.

On the other hand, if I run ‘asterisk -cvvvv’ asterisk starts just fine and I am able to connect to it by issuing ‘asterisk -rvvvv’.

Any help/insight is greatly appreciated.

The SELINUX is disabled?

SELINUX was enforcing. I’ve disabled it, rebooted and now all is well. Thank you very much navaismo.