Sending no Caller ID

How does one send NO caller ID in Asterisk?

same => n,Set(CALLERID(num)=)
same => n,Set(CALLERID(name)=)

does not work, as the incoming caller ID “Asterisk”.
I don’t want to set the presentation, but even same => n,Set(CALLERID(pres)=unavailable) doesn’t work completely right, as I see “PRIVATE NO” / “PRIVATE NAME” on my display. That is obviously display-specific, but per the manual for this device, if no Caller ID is sent, it will display “ERROR”. There is a very specific case where I don’t want to send any CLID information from Asterisk at all and it seems to want to prevent that kind of behavior at all costs.

How can I prevent any CLID information from being sent by Asterisk? I looked in callerid.c, but I don’t see any references there to a default string if none is provided (like “ASTERISK”) that I can remove. Anybody familiar with how this is architected?

Hello,

try with:

same => n,Set(CALLERID(num)=anonymous)
same => n,Set(CALLERID(name)=anonymous)

regards

I use this which works well: Set(CALLERID(all)=)

How does this help? That just sends the caller ID to “anonymous”, not removes it.

That seems like it ought to work -

Unfortunately, it’s the same thing, I tested on a few different agents and they all show “ASTERISK” as the caller ID.

It seems I may have to compromise and just block the presentation for now. Perhaps this is a limitation of SIP.

those are the default setting of PJSIP (endpoint) if you haven’t modified them :

;send_pai=no ; Send the P Asserted Identity header (default: “no”)
;send_rpid=no ; Send the Remote Party ID header (default: “no”)
;rpid_immediate=no ; Send connected line updates on unanswered incoming calls immediately. (default: “no”)
;trust_id_inbound=no ; Accept identification information received from this endpoint (default: “no”)
;trust_id_outbound=no ; Send private identification details to the endpoint (default: “no”)

switching on a few might help

I’m using SIP, not PJSIP, but it sounds like what you’re saying is that it’s channel-type specific. I’ll take a look.

Try setting ‘useragent’ in sip.conf under the ‘general’ section to something like:
useragent=name