Secondary WAN IP issue

I have a customer that has two separate WAN providers. They have a Router that will do the failover from one to another. Our problem is that the WAN Ip in the system stays the same when they failover to the secondary. Is there a way to put a WAN IP in the peer details to send and override the system settings? I can setup two trunks one with the primary WAN IP and the other with the secondary WAN Ip address. We can’t use DDNS as the trunk provider will not use a FQDN.

In the “general” settings of sip.conf, instead of using exernip, sign up with a DDNS provider and use externhost and put your FQDN in there. (If you are using chansip, I don’t know what that setting is called for pjsip in pjsip.conf)
Asterisk will perform DNS quieres periodically and update your external IP when it changes.

Then let your trunks register to your sip trunk providers. They will send traffic to whatever IP address the registration came from.

You mean they don’t provide FQDNs to register to? No problem, you don’t need that.

On PJSIP channel driver you can use the options :


independently for each SIP , configuring different transport sections and using them

I am using Freepbx and there is no pjsip available for trunks.

ESI is the trunk provider and they will not allow outgoing traffic from the secondary IP, even if I send the primary ip from the system.

Yes there is.

Why is ESI not allowing traffic from your secondary IP?
What happens if your primary WAN is down, your secondary active, you press the “detect external IP” button in Chansip settings in Freepbx, does your trunk then register and do you use registration at all?

Yes that will work AFTER we contact them to change the WAN IP in their settings. They will use two Wan Ips to SEND calls but for outgoing not so much. We let the dealer know his options and he will determine what to do.