Sangoma A101 with Adtran 750


#1

I’m trying to move from my X100P clone to the next level…

I’ve purchased a Sangoma A101 and an Adtran 750. The TA750 has 4 FXS modules and 2 FXO modules. I’m using a T1 crossover cable to connect the two.

I’ve got everything compiled and installed (ast/zap/pri-1.2), and have run wancfg. When I run “wanrouter start” the channel bank’s LEDs, all of them, click incessantly until I run “wanrouter stop”. I’ve goofed something up.

Here are my config files:

zapata.conf

[channels]
signalling = fxs_ks
channel => 1-16
signalling = fxo_ls
channel => 17-24

zaptel.conf

#zaptel.conf [16 FXS 8 FXO]
span=1,0,0,esf,b8zs
fxsks=17-24
fxols=1-16
loadzone=us

Where else should I look for what’s wrong?


#2

Okay. The clicking sound from the TA750 ended up being ringing. It appears to ring continuously until I start Asterisk. I’m still trying to get things working, FXO ports appear to be OK, but the FXS side isn’t giving me a dial tone. Here are my config files so far:

;wanpipe.conf
[devices]
wanpipe1 = WAN_AFT, Comment

[interfaces]
w1g1 = wanpipe1, , TDM_VOICE, Comment

[wanpipe1]
CARD_TYPE = AFT
S514CPU = A
CommPort = PRI
AUTO_PCISLOT = NO
PCISLOT = 2
PCIBUS = 1
FE_MEDIA = T1
FE_LCODE = B8ZS
FE_FRAME = ESF
FE_LINE = 1
TE_CLOCK = NORMAL
TE_REF_CLOCK = 0
ACTIVE_CH = ALL
TE_HIGHIMPEDANCE = NO
LBO = 0DB
FE_TXTRISTATE = NO
MTU = 1500
UDPPORT = 9000
TTL = 255
IGNORE_FRONT_END = NO
TDMV_SPAN = 1
TDMV_DCHAN = 0

[w1g1]
ACTIVE_CH = ALL
TDMV_ECHO_OFF = NO

;zapata.conf
[channels]
signalling=fxo_ks
channel => 1-16

group = 2
signalling=fxs_ls
channel => 17-24

;zaptel.conf
span=1,0,0,esf,b8zs
fxoks=1-16
fxsls=17-24
loadzone=us


#3

I’m all set!

Logging into the BCU and setting the FXS modules to “FXO Loopstart” did the trick. All Zap channels are up and running.