Running error: load_modules: No 'modules.conf' found - 1.4.1

Hi All!

I have just installed the fresh svn version of asterisk and when I run it I get the following errors:

[Mar 4 14:19:27] WARNING[24527]: loader.c:728 load_modules: No ‘modules.conf’ found, no modules will be loaded.
[Mar 4 14:19:27] NOTICE[24527]: manager.c:2681 init_manager: Unable to open management configuration manager.conf. Call management disabled.
[Mar 4 14:19:27] NOTICE[24527]: cdr.c:1093 do_reload: CDR simple logging enabled.

I get this errors although my astetcdir contains the above considered files??
Does asterisk searched for those files in other directory than astetcdir??

the contents of my asterisk.conf:

astetcdir => /home/asterisk/asterisk/asterisk
astmoddir => /home/asterisk/asterisk/lib/asterisk/modules
astvarlibdir => /var/lib/asterisk
astdatadir => /var/lib/asterisk
astagidir => /var/lib/asterisk/agi-bin
astspooldir => /var/spool/asterisk
astrundir => /var/run/asterisk
astlogdir => /var/log/asterisk


Any update on this?
I ran into the same problem today installing Asterisk 1.4.2.

yes u need to run asterisk with the config file parameter, because bydefault it searches in the hardcoded location


Sounds like a bug to me. It should check in PREFIX/etc/asterisk/