RTP traffic not direct, ASR not working

Hi guys,

I have a strange problem with Asterisk

I am calling Voxpilot from X-Lite via Asterisk. Voxpilot and Asterisk are in the same private network and the X-Lite client is in another private network.

The problem is that ASR in Voxpilot doesn’t work. I am thinking maybe the audio traffic flows only in one direction, but I tested with another X-Lite client sitting on the same machine as Voxpilot and I was able to establish a successful call.

If I call voxpilot directly from X-Lite (no asterisk involved) everything works fine. In this case the RTP stream is peer to peer, so I was trying to get Asterisk to do only SIP signaling and allow the RTP traffic to flow directly between the peers. Maybe this would solve my problem.

I played with


in sip.conf

in all possible combinations and analyzed the packets with wireshark. I all cases RTP goes through Asterisk and ASR is not working. I experience the same problem when I use a GSM phone instead of softphone.

I also called from softphone in the same network as * and still no ASR.

If anybody could point me out the direction I should look at I will be very grateful.

Angel Kafazov

Hi guys,

in case somebody encounters this problem, the issue was the pcma codec in asterisk. It turns out voxpilot doesn’t like it, and after disabling pcma in sip.conf only the pcmu is used. It worked out very well.