RTP payload type switches every 2 packets


I have a strange problem with one of our asterisk installations.

A while ago we noticed, that some incoming calls had a very bad sound quality while others were ok. Sometimes this would persist through the whole call, sometimes this would resolve itself after a few seconds. When the problem occurs, the sound get very “jittery” or “shivering” and is very hard to understand.

I’ve now looked deeper into it and noticed, that the RTP payload type on the problem calls switches every 2 packets from 0(ulaw) to 8(alaw) and back again.

I changed the allowed codices to g722, alaw, ulaw and only to alaw, but the problem persists, even when I forbid the usage of ulaw. If I add g722, it starts switching between payload types 9 and 0.

Has someone an idea what could cause this?

The PBX is an Asterisk 16 on Debian 10, which still uses res_sip
Interestingly the problems started a short while ago, while the last change to the sip connection settings was years ago…

Do you try with codec G7.29? I think your Asterisk has a problem with transcode. The bad audio comes from your Asterisk or the other side?

I haven’t tried g729 yet, but since that codec is not supported by every other pbx, it wouldn’t really help if it really did work.

I noticed though, that I forgot to use disallow=all before allow=alaw, so ulaw was still enabled by default and not disabled. So if I use disallow first and really only enable alaw, it does actually fix the problem. It is still very strange that this problem happens in the first place when multiple codices are enabled.

The bad audio comes from our side.

I also noticed, that it also depends on the other side. The problem only occurs with some other providers/pbxes. It does not happen every call though.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.