Ring tone stops after second ring

I have running asterisk on centos5 working ok, but there is a small problem. On outgoing calls and calls to other extension the ringtone at callersite stop after second ring and you hear nothing until the other end picks up the phone.

Location: Spain, we use national public phone numbers for extensions


exten => _[6789]XXXXXXXX,1,Dial,(SIP/PROV/0034${EXTEN},30,r)
exten => _[6789]XXXXXXXX,n,Hangup

exten => _970123456,1,macro(interno,${EXTEN})
exten => _970123457,1,macro(interno,${EXTEN})

exten => s,1,Dial(SIP/${ARG1},30,r)
exten => s,2,GotoIf($["${DIALSTATUS}" = “BUSY”]?100:3)
exten => s,3,Voicemail(${ARG1}@default,u)
exten => s,4,Hangup
exten => s,100,Busy(10)
exten => s,101,Hangup


– Executing [900101010@default:1] Dial(“SIP/970123456-00000492”, “SIP/PROV/0034900101010,30,r”) in new stack
== Using SIP RTP TOS bits 184
== Using SIP RTP CoS mark 5
== Using UDPTL TOS bits 184
== Using UDPTL CoS mark 5
– Called PROV/0034900101010
– SIP/PROV-00000493 is making progress passing it to SIP/970123456-00000492
– SIP/PROV-00000493 answered SIP/970123456-00000492
– Packet2Packet bridging SIP/970123456-00000492 and SIP/PROV-00000493

Any help would be apreciated

You are getting a transition to in band progress. Recent versions of Asterisk require that you explicitly call the Progress application if you want in band progress signalling to be passed through. (There may be cases where this is not possible without starting charging the incoming caller.)

Thank you david.

I finally fixed it !!!
It had nothing to do with asterisk. I use SPA2102 ATAs and in regional settings Ring Back Tone was set to 425@-10;10(1/4/1). I copied this value from some site announced as values emulating spanish telefonica settings.
Now i changed the value to 425@-10;40(1/4/1) and everything goes fine!