[Resolved] Zap show channels not shows any channel?


In the Asterisk CLI the command “zap show channels” shows this:

********* cut ***********

localhostCLI> show version
Asterisk built by root @ unit0 on a i686 running Linux on 2006-10-08 06:47:47 UTC
CLI> zap show channels
Chan Extension Context Language MusicOnHold
pseudo default

****** end cut ********

I think it could be some channel more in my TDM400P with 4 FXO channels.
Is there som misconfiguration here?
( By the way, I can’t recieve any call from “outside” - the Asterisk CLI do not shows anything, but I can make “inside” calls)

Thank you.

probably, post zapata.conf, zaptel.conf, the end of dmesg immediately after you reload the wctdm driver and the output of ‘ztcfg -vvvvv’ too.

Here is:





answeronpolarityswitch=yes ;;; <estas son
hanguponpolarityswitch=yes ;;; <estas son

channel => 1-4 ; <el canal ZAP que sea.
;channel => 3

Here is zaptel.conf:


[root@localhost etc]# ztcfg -vvvvv

Zaptel Configuration

Channel map:

Channel 01: FXS Kewlstart (Default) (Slaves: 01)
Channel 02: FXS Kewlstart (Default) (Slaves: 02)
Channel 03: FXS Kewlstart (Default) (Slaves: 03)
Channel 04: FXS Kewlstart (Default) (Slaves: 04)

4 channels configured.

[root@localhost etc]#

Here is dmesg:

Zapata Telephony Interface Registered on major 196
Zaptel Version: Echo Canceller: KB1
Registered Tormenta2 PCI
ACPI: PCI interrupt 0000:02:0a.0[A] -> GSI 22 (level, low) -> IRQ 217
Freshmaker version: 73
Freshmaker passed register test
Module 0: Installed – AUTO FXO (FCC mode)
Module 1: Installed – AUTO FXO (FCC mode)
Module 2: Installed – AUTO FXO (FCC mode)
Module 3: Installed – AUTO FXO (FCC mode)
Found a Wildcard TDM: Wildcard TDM400P REV I (4 modules)
Registered tone zone 6 (Spain)
usbcore: registered new driver wcusb
Wildcard USB FXS Interface driver registered
Registered tone zone 6 (Spain)
Registered tone zone 6 (Spain)
eth0: network connection up using port A
speed: 100
autonegotiation: yes
duplex mode: full
flowctrl: symmetric
irq moderation: disabled
scatter-gather: enabled
SELinux: initialized (dev rpc_pipefs, type rpc_pipefs), uses genfs_contexts
i2c /dev entries driver
eth0: no IPv6 routers present
parport0: PC-style at 0x378 (0x778) [PCSPP,TRISTATE,EPP]
parport0: irq 7 detected
lp0: using parport0 (polling).
lp0: console ready
Registered tone zone 6 (Spain)
[root@localhost etc]#

Thank you.

Its resolved. Thanks to baconbuttie.

The mistake was “[chanels]” and must be “[channels]” in the zapata.conf file.

Thank you.