[RESOLVED] Extremely Low Audio with new TDM808B

Hi all,
I’m rolling out my new AsteriskNow 1.4.9 system, with a TDM808B card installed.
I currently have 7 POTS lines coming into the system, but am having a problem with low audio volume for calls coming into the system.
With intercom calls, the volume is fine.
With calls to/from the PSTN, the person on the PSTN-end of things can hear us fine.
We can hear them, but the volume is extremely low.
I called Digium support on this yesterday, and their response was to edit the rxgain and txgain settings in zapata.conf.
I’ve adjust both up from 0.0 to as high as 8.0, but there has been no change in the volume.
I’ve used the AsteriskNow GUI to restart Asterisk after each change, but no change in volume has been detected.
Thinking that I wasn’t doing this correctly, I shut down and restarted the Asterisk box.
When the system came back up, the rxgain and txgain settings were reset to 0.0!
Not sure if this is the cause of the problem, or if I have hardware issues.
Does anyone have any ideas?

try running ‘fxotune’ from the zaptel source directory.
This will set up the line matching in the FXO ports and may improve things.

The full command is like
/usr/src/zaptel-1.4.4/fxotune -i

Zaptel should be running, but Asterisk must be stopped.

(For anyone in the UK, use -i 1 as the default does not give a quiet line).

You also need to add fxotune -s in your /etc/rc.d/rc.local to load the configuration when the system starts, after zaptel but before asterisk.
(It’s probably a good idea to copy or link fxotune to /usr/sbin/fxotune)

Thanks, I’ll give this a try.

Just finished up four frustrating hours trying to get fxotune to work.
When running fxotune, I ran into the “could not fill input buffer” error message. I found a wiki article with some suggestions on how to get around this ( fxotune -i and a phone # that won’t answer ).
I still got the error messages.
It did create an fxotune.conf file, though.
The how-to all mention that I need to put the fxotune -s inthe system startup scripts, after zaptel loads, but before asterisk loads.
One article mentions that the AsteriskNow 1.4 automatically detects the existance of the fxotune.conf file and handles this for me, but I see no evidence that this is actually happening.
Anyway, I don’t know where the system startup scripts are to edit them. ( linux newbie.)
I’ve also manually set the rxgain and txgain settings in /etc/asterisk/zapata.conf and zapata.conf.zapscan files.
Both rxgain and txgain set to 5.0.
I’ve rebooted the server and verified these settings are in the conf files.
When I dial out to the PSTN, recipient can hear us fine, but we can hardly hear them. We need to put the volume on our phones up to max. This is the same results as having rxgain/txgain set to 0.0, so it doesn’t appear that these settings are even being read. OR… the problem is elsewhere?
Any help on startup script for services or this low volume issue greatly appreciated.
I’ll be coming into the office tomorrow, with the low audio problem. My coworkers have been pretty patient up 'til now, but I sense that the natives are getting restless.
Any possibility that I’ve got a bad card?
BTW, if I hook up a POTS phone to each of the PSTN lines, no volume issues exist.
Please don’t make me have to install Microsoft’s telecom app!!! My boss is asking about that as a fall-back. (kill me now) :wink:

I use Asterisk + FreePBX, manually compiled on Centos 4.4 so I’m not familiar with some of the files you mention.
(I’d consider using FreePBX - from what I read on here, I get the impression that it’s far more user-friendly at this moment in time).

Assuming you are on Centos or Fedora etc., there should be a ‘setup’ command that allows you to enable & disable system services.
Zaptel & Asterisk could be in there?

My normal startup method is disable them in setup, then use the /etc/rc.d/rc.local file to sequence the startup, like


service zaptel start
sleep 5
/usr/sbin/fxotune -s
#sleep 1
sleep 2
amportal start
sleep 5
festival_server 2>&1 >/dev/null &


Re. the levels, I have a setup at a customers site that needs that needs a lot of rxgain to get incoming audio to a reasonable level. On that I have

rxgain 15 txgain 3

remember the gain settings must be before any
channel=> lines that you want them to affect.

You can run fxotune on one line at a time using -b 1 -e 1 (beginning & end channels), however you will then have to copy the line for that channel from the file it produces, as it creates a new file each run…
Once you have all the channel lines, re-create the file and save a backup…

Digium proactively contacted me.
I gave them remote access to my system, and they tracked down the problem to needing a newer zaptel driver.
They had the problem diagnosed and fixed in about 40 minutes.
Amazing technical support! :smiley:
The natives have put away their torches, and I think it is safe for me to leave my cube!
With the new zaptel version, fxotune, rxgain and txgain are all working fine.
Thanks for the suggestions and help!

Thats why I always recommend people buy Digium cards - there support is EXCELLENT.

I had a similar experience, Digium support is awsome…Kudos to all the guys (and gals) at Digium. I love companies that still cater to the customer…all these other huge companies (Comcast, SBC, Sprint, etc) can fall off a cliff as far as I am concerned. My money goes to the little guy!