[RESOLVED]Call connects but no far end video

I’ve setup asterisk with webrtc2sip on virtualbox on my office pc. it is currently setup with a NAT port and a Host-Only port. asterisk and my pc should be communicating over the host-only port. I think ice setup is travelling over the NAT port since it has to reach the internet. i’ve used both jssip and sipml5 clients, they are able to register and audio only calls work great! when I try a video call, the call completes but I am only seeing local video on the clients when using jssip. if i start a video call using sipml5 one side gets local and far end video, the other side only gets local video. The audio in this case still flows both ways.

I’m running asterisk 12.5 on Ubuntu server 14. the IP of the server host only network is a 192.168.56.x address, it also seems to be picking up on my workstations network IP(172.x.x.x) as well as using my public IP(66.210.x.x). since I can’t get bridged networking to work on VBox, is there a way to get this setup to work?

any help at all is greatly appreciated.

asterisk log file
http://pastebin.com/embed_js.php?i=EDwLLdjV
sip.conf
http://pastebin.com/embed_iframe.php?i=pW7YzmKA
sipml5 client receiving one way video
http://pastebin.com/embed_js.php?i=jQghGz9a
sipml5 client bidirectional video
http://pastebin.com/embed_js.php?i=AYfabMLK

If any additional documentation is needed to help resolve the problem please let me know. I’m reading up on setting the asterisk up behind a nat but i’m not sure this will work given the situation.

if anyone’s wondering or finds this in a search I was able to resolve this. first i disabled the host only adapter on my vbox installation and went with nat only since I can’t do bridged on my network. then in rtp.conf i limited the number of ports for rtp traffic to 10000 to 10250 and opened all those ports using a quick shell script in windows. my internal address remains the auto-assigned 10.x address vbox gives by default and my external address is the host pc’s IP. when natting in vbox for some reason I had to specify IP’s rather than using the 0.0.0.0 configuration but that was solved easily with he shell script.