Requesting 3.1KHz Audio over ISDN BRI


#1

Hi all!

I have an interesting, but annoying problem. I am using * 1.0.10 with two HFC-based ISDN BRI cards, and I am pretty happy with the setup - except when making international calls. Namely, during the ISDN call setup, Asterisk always requests 64k digital line when making outgoing calls. My Telecom provider happily provides the link for local and national calls - but, since they can not guarantee 64k trunk for international calls - the line gets disconnected from provider’s side, and the call does not happen. As I have talked with people from Telecom, the solution is to request simple 3.1KHz audio link, and the call will be connected - otherwise it will be refused with Cause 3 - no route to destination.

So, my question is : how to force Asterisk to request 3.1KHz audio link over a digital ISDN line?

Here is a snippet from BRI debug :

> Protocol Discriminator: Q.931 (8)  len=28
> Call Ref: len= 1 (reference 7/0x7) (Originator)
> Message type: SETUP (5)
> [04 03 80 90 a3]
> Bearer Capability (len= 5) [ Ext: 1  Q.931 Std: 0  Info transfer capability: Speech (0)
>                              Ext: 1  Trans mode/rate: 64kbps, circuit-mode (16) <- This is what I'm talking about!
>                              Ext: 1  User information layer 1: A-Law (35)
> [18 01 81]

If someone can help, I will really appreciate it - since large majority of outgoing calls will be international calls!

Thanks in advance!


#2

Hehehe…ya, some user dont figure that their calls are rejected by faxSOFTWARE set to “dont answer speech calls”.

You did, yay :smile:

Here is how to. Check your originating phone. If it is the local faxmachine (lets say extension 40, you switch - else NOT):

exten => _0N.,1,Set(faxi=${CALLERID(number)})
exten => _0N.,2,GotoIf($["${faxi}" = “40”]?3:4)
exten => _0N.,3,SetTRANSFERCAPABILITY(3K1AUDIO)
exten => _0N.,4,Normal continue with dialplan

That is doing:
(0 is to dial out on PSTN lines)
Check the orig…if it is extension 40 continue at prio 3 (setting 3K1 audio), else cont. at prio 4 : Which is no mod-change and normal call continue.


#3

[quote=“RichardHH”]Hehehe…ya, some user dont figure that their calls are rejected by faxSOFTWARE set to “dont answer speech calls”.

You did, yay :smile:

Here is how to. Check your originating phone. If it is the local faxmachine (lets say extension 40, you switch - else NOT):[/quote]

Actually, this has nothing to do with the fax - more with the Telecom’s inability to provide needed 64k digital link. But, the result should be the same. Thanks for the tip !!!


#4

Huh ? How that ?

They cant fulfil the technical (contracted) requirements for a standard ISDN line ?!?!

What provider is that ?
“Quick & Dirty incompetent ltd.” ? :laughing:

Edit:
Ok, ive read your intitial posting carefully again, i understand now :bulb:

Hmm…i think that is not true tho: The ISDN line is made from your asterisk to your provider: Which will be always 64K up to that point. The “conversion” then should be made inhouse by the telco, but not affecting your (64K) side ?! Sounds like they just pass the call…

PS.:
The bearer cap. is just flagging the SERVICE for a call, not its technique…your telco isnt “Brothers Grimm” no ? :stuck_out_tongue:


#5

[quote=“RichardHH”]Huh ? How that ?

They cant fulfil the technical (contracted) requirements for a standard ISDN line ?!?!

What provider is that ?
“Quick & Dirty incompetent ltd.” ? :laughing:
[/quote]

Something like that, yes :smile: :smile: :smile:

When talking to folks from the Telecom, they told me that they try to provide that kind of service end-to-end, not only for local, but also for international calls - and they can not always guarantee full 64k digital link for international (so it’s all or nothing, never mind the best effort thingy).

Most notable example : when I dial a local number with MSN only, I get the connection without a problem. When I dial that same number, but fully qualified (i.e. IAC+CC+NDC+MSN), I get disconnected before I blink.

And it is not a dialplan issue, since the outgoing line gets opened and a call setup begins. And ends before I know it.


#6

That is CLEARLY indicating, what absolutely nonsense and bull they have configured.

You need to know how they work. They have switches and “routings”, think of network routings/tables.

So you call comes in on eg. “Switch Alabama-east 1”, target is your own number, if prefixed or not - its a number flowing throught their very own inhouse logic.

So the call jumps (eg.) from
"Switch Alabama-east 1"
to
"Switch Alabama-east 2"
to
"Switch Alabama-NOC main"
back to your local switch.

And THERE already is a 64K loss ?

They should think about a hotdog stand…


#7

[quote=“RichardHH”]
That is CLEARLY indicating, what absolutely nonsense and bull they have configured.
[/quote] Exactly. My guess is that they refuse to give 64k digital line the moment they detect IAC dialing, regardless of the destination.

[quote=“RichardHH”] You need to know how they work. They have switches and “routings”, think of network routings/tables.
[/quote] I know, believe me. I work for a Mobile Telecom operator.

[quote=“RichardHH”]
They should think about a hotdog stand…[/quote]
They are a monopoly operator, so they do whatever they want. No competition, no development. Simple as that.

However, if this SetTransferCapability app can affect the call setup, then I guess all will be ok.


#8

Well, after all, it did not help. It indeed sets the requested transfer capability to 3.1K audio, but the transmission stays just the same - 64k digital :


> Message type: SETUP (5)
> [04 03 90 90 a3]
> Bearer Capability (len= 5) [ Ext: 1  Q.931 Std: 0  Info transfer capability: 3.1kHz audio (16) <-- This is OK, but...
>                              Ext: 1  Trans mode/rate: 64kbps, circuit-mode (16) <-- this is not....
>                              Ext: 1  User information layer 1: A-Law (35)
> [18 01 81]

Any other ideas? Please help - I’m stuck here…


#9

[quote=“nvanevski”]
Any other ideas? Please help - I’m stuck here…[/quote]

Yes, change your provider (seriously).

No sense in “acrobatic workarounds” to fix their crap.
A FORCED! bearer cap, set to 3K1 should exactly do what its intended to do.

If even THIS is not handled correct by your provider, fire the noob…


#10

Easier said than done, especially when these guys are the only provider.

Ok, but how do I do this?


#11

Easier said than done, especially when these guys are the only provider.

Ok, but how do I do this?[/quote]

You dont, the ISP does:

->Customer is sending “3K1” flag
-> ISP receives the flag and SHOULD act appropiate

Step 2 is where the “case 3K1” was terminated… :imp:

What you mean by “only provider” ?
Where you at ? Upper mountain chain of the Himalya ? :open_mouth:


#12

[quote=“RichardHH”]What you mean by “only provider”?
Where you at ? Upper mountain chain of the Himalya ? :open_mouth:[/quote]

A little bit less civilized : Macedonia, the only country in Europe with a telecom monopoly.

Ok, seems that the only thing that remains to be done is to debug the ISDN on both sides and to ask the provider to make some adjustments (if possible) on their side.

Thank you for your time and patience !!


#13

NP buddy !

Macedonia…nice…was not bad in the last European Song Contest :exclamation: