Remove "line" from contact on PJSIP Trunk

Hi all

I’m trying to move a SIP trunk from chan_sip to chan_pjsip.
Everything looks good, registration, incoming calls, etc. But I can’t make any outgoing calls.

The provider support claims the issue is the Contact header, when I’m registering with chan_pjsip there is additional note at the end like:

Contact: <sip:XXXXXXXXX@;line=mmmeexj>

Is there any way I can remove this line tag and get a clean Contact like in chan_sip?

Contact: <sip:>

For now I re enables chan_sip only for this trunk.

Thanks in advance.

I’m using FreePBX official latest distro with Asterisk 16.9.0

I can’t speak for FreePBX, but that is a configurable item on the outbound registration - specifically the “line” option.

Well after hours of fighting with config files I finally got this error:

ERROR res_pjsip_outbound_registration.c: An endpoint has been specified on outbound registration XX without enabling line support.

I don’t want line support, what can I do?

You need to also remove the “endpoint” field.

Wow, you did it!
It get registered without this ‘line’, but I guess I have to find a way to do it through FreePBX because now Asterisk answer Forbidden toany OPTIONS from the sip trink provider and when trying to make outgoing call I get

Unable to create PJSIP channel - endpoint 'XXX' was not found.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.