Remote (called) Party Identification patch

Has anyone been able to patch asterisk 1.4.x or 1.6.x as stated on https://issues.asterisk.org/view.php?id=8824 ??

I have tried the to patch 1.4.18, and 1.4.23.1 as stated but the patch not working and thus cant compile asterisk.

only worked with version 1.4.21.1 but as soon as you dial another extension, asterisk crashes.

All of the work to support COLP/CONP was merged into 1.8. If you need this feature, you’re best off using 1.8

Cheers.