Reload command causes Zap channel to be congested


#1

My current system confiiguration is:
Asterisk 1.2.4 on a Dell PowerEdge 2850 w/ a Digium TE411P card

We use 2 T1 PRI lines (one for local calls, one for LD calls)

The problem I am experiencing is that every time I use the ‘reload’ command we are unable to make calls out our local T1 line - ZAP/g1 (span 1 on the card ). Long distance calls made on ZAP/g2 (span 3 on the card) work without any problems.

Restarting Asterisk resolves the problem everytime. Obviously, that’s not a very viable option as we constently have calls in progress.

Below is the console output:

– Executing GotoIf(“SIP/183-db43”, “1?s|3:s-NOSTRIP|1”) in new stack
– Goto (macro-tl-dialout,s,3)
– Executing Set(“SIP/183-db43”, “CALLERID(number)=206XXXXXXX”) in new stack – Executing Dial(“SIP/183-db43”, “ZAP/g1/4415555”) in new stack
Mar 1 12:54:40 NOTICE[16839]: app_dial.c:1011 dial_exec_full: Unable to create channel of type ‘ZAP’ (cause 34 - Circuit/channel congestion)
== Everyone is busy/congested at this time (1:0/1/0)
Mar 1 12:54:40 DEBUG[16839]: app_dial.c:1587 dial_exec_full: Exiting with DIALSTATUS=CONGESTION.

‘Show channels’ will show the current number of active calls - typically 6-12 calls.

Has anyone seen a behavior like this? Any suggestions?

Thanks,
AntD


#2

I hate finding a post from someone that has the exact same problem, but not seeing any resolution…

I was able to resolve my problem with the reload command causing congestion on my ZAP channel with the below steps.

In zaptel.conf I had the following entry:
span=1,1,0,esf,b8zs,yellow

I changed the entry to this:
Span-1,1,0,esf,b8zs

Basically, no ‘yellow’ parameter.

I can reproduce this problem at will be re-adding the yellow parameter.

Looks like a bug.

-AntD