Reg: problem in configuring the asterisk libsrtp file

Hi guys,
I am installing asterisk 11 version in my machine with fedora os installed in it. I followed the steps mentioned in the following URL.
Everything goes well, but while executing the configuration setting mentioned in 4th point i got the below mentioned error
checking for the ability of -lsrtp to be linked in a shared object… no
configure: WARNING: ***
configure: WARNING: *** libsrtp could not be linked as a shared object.
configure: WARNING: *** Try compiling libsrtp manually. Configure libsrtp
configure: WARNING: *** with ./configure CFLAGS=-fPIC --prefix=/usr
configure: WARNING: *** replacing /usr with the prefix of your choice.
configure: WARNING: *** After re-installing libsrtp
configure: WARNING: *** configure script.
configure: WARNING: ***
configure: WARNING: *** If you do not need SRTP support re-run configure
configure: WARNING: *** with the --without-srtp option.

From the error i too tried manually compiled libsrtp file. Still the problem in configuring exists. Could someone please help me regarding this.


Which file are you talking about? You need to download the libsrtp sources and compile it with that commands.

Or you can try to download via repos.

Thanks for the reply navaismo,
i changed the configuration setting a bit as follows
./configure --with-crypto --with-ssl --with-srtp= --prefix=$PREFIX
and it worked fine…

and done “make, make runtest” all worked perfectly, But while executing "make install"
i get the problem with wget in linux as
"HTTP request sent, awaiting response… Read error (Connection reset by peer) in headers."

have you came across any similar issue, if so please help regarding this.

Thanks in advance

Check your internet/DNS settings seems like you can’t reach the files to download.