Reg: Issue in Auto-Answering the incoming call

Hi Guys,

I am facing issue in auto-answering the incoming calls in Asterisk 11. Here, i have given the dial plan (extensions.conf)

include = DLPN_Test
exten => _X.,1,NoOp(“Click to Call Originator”)
exten => _X.,n,Set(_ALERT_INFO=info=alert-autoanswer)
exten => _X.,n,Goto(from-internal,${EXTEN},1)

include = DLPN_Test
exten => _X.,1,NoOp(“Click to Call Target”)
exten => _X.,2,Goto(from-internal,${EXTEN},1)

include = DLPN_Test
exten => _X,1,Dial(${EXTEN})

Whereas, i mapped all extensions in “DLPN_Test” context.

I used the following Originate Action to make a call from extension 6002 to extension 6003. I registered both extensions in different x-lite.

Action: Originate
Channel: Local/6002@click-to-call-originate-custom
Exten: 6003
Priority: 1
Context: click-to-call-target-custom
Timeout: 10000

Now, I am getting call to source extension 6002 to manual answer, instead of auto-answering and then call made to destination extension 6003 and connected.

Here, i need to auto-answer source end. I am not sure, where i made mistake. please assist me on this.

Thanks in advance.

Best Regards,

I don’t see an AddHeader application call.

I’m also only guessing that you are using SIP.

Hi David,
I too facing the same issue. And in my case also i am using the similar Dial plan and trying with SIP channel type.
I am connecting to asterisk using telnet and while trying to execute the originate action it’s making a call to source extension and then on attending the call from source extension(i.e Extension 6002 from above example) then the real call ends to designation(i.e. Extension 6003). so i am trying to auto answer the call in source extension side i am getting issue while auto answering.

Could you please help me to get out of this.

Best Regards

Find out how you make the phone auto-answer (typically a custom SIP header, and a configuration option on the phone (as there are security reasons why you would not want the header to work out of the box)).

Assuming it is a custom header, use a local channel, as the OP was doing, and invoke AddHeader to add that custom header.

Thanks for your reply David,

I tried all following possibilities in the dialplan. Still i am not overcome the issue.

include = DLPN_TestSathish
exten => _X.,1,NoOp(“Click to Call Originator”)
;exten => _X.,n,SIPAddHeader(Alert-Info: autoanswer)
;exten => _X.,n,SIPAddHeader(Alert-Info: ;info=alert-autoanswer)
;exten => _X.,n,Set(_ALERT_INFO=info=alert-autoanswer)
;exten => _X.,n,SIPAddHeader(Alert-Info: Ring Answer)
exten => _X.,n,SIPAddHeader(Alert-Info: sip:;info=alert-autoanswer)
exten => _X.,n,SIPAddHeader(Call-Info: sip:;answer-after=0)
exten => _X.,n,Goto(from-internal,${EXTEN},1)

Currently i am using xlite softphone. Do I achieve auto answer in xlite softphone through dialplan? (without any manual changes in xlite to auto answer).


Given X-Lite is a loss leader, I would be surprised if it supported that feature.