Realtime issue and upgrade from 1.4 to 1.6

After 2 days pull hair struggling, I found that in Asterisk realtime table sip_buddies, you must have username and name the same, before you can successfully register a realtime user, it is wired.

Secondly, I tried to upgade the 1.422 to 1.6 release, but after I run: make clean, make make install, the asterisk can not startup(but If I install version 1.6 before 1.4, version 1.6 can start properly, also I can downgrade to 1.422 successfully.

The error message I get after ungrade from 1.4 to 1.6 is “Unable to connect to remote asterisk (does /var/run/asterisk.ctl exist?)”.

Any ideal?

Sounds like your “old” Asterisk is still running.

Check if that is the case by entering

if it is still running you have to logon usingasterisk -rand stop the running system by entering stop gracefully.

Thereafter you can start 1.6 and you should be fine

Thanks for you respond.

I have another issue.

I can not find the mysql and realtime support on asterisk-addon-1.6, when I did make menuselect, there is no mysql and realtime modules in it.

Any clue?

Unfortunately I don’t as I have never used that. Sorry.