Queue show not in use, but active

We have an running asterisk 11.21 on elastix 4 on which everything is good :slight_smile:

We want to do the same with freepbx and asterisk 13.29, but I see a small difference and I don’t know where to change it.

In asterisk 11.21, when an extension is active (in call), I still see not in use the queue show:
500 has 0 calls (max unlimited) in ‘rrmemory’ strategy (13s holdtime, 149s talktime), W:0, C:1112, A:13, SL:97.7% within 60s
Local/565@from-internal with penalty 1 (ringinuse disabled) (dynamic) (Not in use) has taken 1 calls (last was 580 secs ago)
Local/564@from-internal with penalty 1 (ringinuse disabled) (dynamic) (Not in use) has taken no calls yet
Local/563@from-internal with penalty 1 (ringinuse disabled) (dynamic) (Not in use) has taken 4 calls (last was 514 secs ago)
Local/562@from-internal with penalty 1 (ringinuse disabled) (dynamic) (Not in use) has taken 13 calls (last was 601 secs ago)
Local/519@from-internal (ringinuse disabled) (dynamic) (Not in use) has taken no calls yet
Local/517@from-internal (ringinuse disabled) (dynamic) (Not in use) has taken no calls yet
Local/516@from-internal (ringinuse disabled) (dynamic) (Not in use) has taken no calls yet
Local/514@from-internal (ringinuse disabled) (dynamic) (Not in use) has taken 1 calls (last was 565 secs ago)
Local/513@from-internal (ringinuse disabled) (dynamic) (Not in use) has taken 19 calls (last was 294 secs ago)
Local/545@from-internal (ringinuse disabled) (dynamic) (Not in use) has taken 3 calls (last was 165 secs ago)
No Callers

This allow the user to transfer the call, and then is avalaible for a new call.

With asterisk 13.29, when an extension is active, it is showed as (in use), and even if the user transfer the call, the queue show it still in use, and then, no new call are transfered to this extension.

What can I do to have same same behaviou in asterisk 13.29 as in 11.21 ?
Thank you and best regards
PS: sorry, i’m not a big user of asterisk, and a little newbie.

Only devices can have in-use states.

There is no device associated with a local channel, so you must specify the state interface of the underlying real device in the queue member definition.

as for free pbx please see snapshot bottom paragraph

read snapshot


Thank you David, but I’m sorry, I don’t understand your answer. Where can I see this definition ? Should I see it in my asterisk 11.21 installation ?
Sorry, i’m really newbie.

Hell benphone
I saw that, and I tried in my freepbx installation all the possibiliy, and I still have the problem. Even after a transfer, it looks like in use, so no new call can come in. Or do you think it is specific to freepbx ? I have the same configuration in the queue of elastix, and it works there.

See the documentation in queues.conf.sample

Thank you david for your help.
I’m not sure what exactly I have to define im my queue. Is it about this configuration option :
; syntax: member => interface,[,penalty][,membername][,state_interface][,ringinuse][,wrapuptime]

Because I don’t have this in my elastix installation. Is it because since asterisk 13, the parameter eventmemberstatus=no is now always yes ?

Thank you and regards

It is the state interface parameter. This forum does not support Elastic (or FreePBX).

Ok, i found my mistake. we use queuemetrics for queue member management. And I defined the /n to the extension. Without it, it works now like with asaterisk.
Thank you for your help, without it I could not found this particular parameter and understand it’s role

Ok, I still have an Problem. Without /n in the extension, the call disapear immediately from the queue, so the wrapeup time now doesn’t work anymore.
If I add the /n, I can’t transfer the calls, and without the wrape up time doesn’t work
Someone has an idea how to handle this ?
Thank you

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.