Queue interface variables not set

Hi all!

I’m running Asterisk 16.3.0 and I noticed that interface variables are not set after answering a call from queue (like MEMBERINTERFACE, MEMBERNAME, etc).
setinterfacevar is set to 1, and setqueuevar too, queues and their settings are coming from DB realtime.
Tried to check the variables right after the call gets answered (queue’s 8th parameter) and after it’s hung up but the result is the same - variables are empty.
The same config worked on ast11 as I moved recently to ast16.

What should I check to make it work?

Maybe try “yes” instead of “1” ?

maybe, you’re right

I checked the table schema at asterisk 16.7.0
mysql> desc QueueList;
±----------------------------±----------------
| Field | Type
±----------------------------±----------------
| name | varchar(128)
| musiconhold | varchar(128)
| announce | varchar(128)
| context | varchar(128)
| timeout | int(11)
| ringinuse | enum(‘yes’,‘no’)
| setinterfacevar | enum(‘yes’,‘no’)
| setqueuevar | enum(‘yes’,‘no’)
| setqueueentryvar | enum(‘yes’,‘no’)
| monitor_format | varchar(8)

Thank you guys, modifying it to enum value solved the problem. Where can I find a description about the required table structure? Maybe I have int values somewhere else too.

Generally, Asterisk uses Alembic to manage changes to database structure.

you can get it from source. like this…

[ippbx@asteriskcti mysql]$ pwd
/tmp/asterisk-16.7.0/contrib/realtime/mysql

[ippbx@asteriskcti mysql]$ ls -la
-rw-rw-r-- 1 ippbx ippbx 1059 Dec 24 01:43 mysql_cdr.sql
-rw-rw-r-- 1 ippbx ippbx 41928 Dec 24 01:43 mysql_config.sql
-rw-rw-r-- 1 ippbx ippbx 1021 Dec 24 01:43 mysql_voicemail.sql

Thank you, very useful.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.